Ask Your Question
0

ros master and android phone cannot connect [closed]

asked 2012-01-01 14:29:16 -0500

rimzahir gravatar image

updated 2012-01-01 14:30:04 -0500

Greetings all,

I'm trying to run the android image_transport tutorial on my android phone, but the application crashes from the start. There was no error when I run the rosmake on the package or when I exported it to my phone. It seems to me that the rosmaster on my computer and the phone can't communicate. I set ROS_IP to the computer (rosmaster) Ip and set ROS_MASTER_URI too. Roscore is running on the computer also. I don't know what I'm missing for the phone to detect the rosmaster running on the computer and connect to it so that the application doesn't crash from the start. Could you please help me figure it out

Thank you for your help

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by damonkohler
close date 2012-01-27 03:52:18

2 Answers

Sort by ยป oldest newest most voted
0

answered 2012-01-05 00:58:11 -0500

damonkohler gravatar image
  • Have you inspected adb logcat? There could be a stack trace in there that would be helpful.
  • Is the tutorial correctly prompting you to enter the master URI?
  • Can you run the android_tutorial_pubsub successfully?
edit flag offensive delete link more

Comments

Thank you for your answer. I can't run the android_tutorial_pubsub either, like the image_transport it crashes from the beginning without prompting anything. I tried it with roscore running in my desktop computer, listener in my desktop computer too but the apllication crashed anyway.
rimzahir gravatar image rimzahir  ( 2012-01-05 01:24:20 -0500 )edit
That's why i think it's a communication problem with the rosmaster not specific to the tutorials. The image_transport tutorial isn't prompting to enter the master URI, it crashes before it gets to this point
rimzahir gravatar image rimzahir  ( 2012-01-05 01:25:41 -0500 )edit
In that case, a stack trace from adb logcat will reveal the problem.
damonkohler gravatar image damonkohler  ( 2012-01-05 01:34:11 -0500 )edit
0

answered 2012-01-01 20:20:56 -0500

michikarg gravatar image

Did you install the ROS applications platform on your robot? I think it is neccessary to communictate via Android...

See:

http://www.ros.org/wiki/ApplicationsPlatform

edit flag offensive delete link more

Comments

Greetings, thank you for your answer. I installed the application that you mentioned from the android market, but it gives me the following message : Cannot contact robot:org.ros.exception.ServiceNotFound . It throws the service not found exception it cannot communicating with the rosmaster either
rimzahir gravatar image rimzahir  ( 2012-01-02 02:52:34 -0500 )edit
Hmm, unfortunately i did not yet find time to test it myself, maybe you could write to the maintainer of the ApplicationsPlatform ROS package? Sorry i cant be of more help in this case...
michikarg gravatar image michikarg  ( 2012-01-03 01:50:35 -0500 )edit

Question Tools

Stats

Asked: 2012-01-01 14:29:16 -0500

Seen: 951 times

Last updated: Jan 05 '12