arm navigation problem on pr2 [closed]

asked 2011-12-13 08:53:54 -0500

zamboni gravatar image

updated 2014-11-22 17:05:11 -0500

ngrennan gravatar image

uys, today I tried some simple tasks on PR2 but I ran in the following problem:

I simply run my file "both_arm_navigation.launch" which consists of:

<launch>
<!-- load perception -->
<include file="$(find pr2_arm_navigation_perception)/launch/laser-perception.launch"/>
<!-- load planning -->
<include file="$(find pr2_arm_navigation_planning)/launch/ompl_planning.launch"/>

<!-- load move_arm -->
<include file="$(find pr2_arm_navigation_actions)/launch/move_left_arm.launch"/>
<include file="$(find pr2_arm_navigation_actions)/launch/move_right_arm.launch"/>

<!-- load planning_environment -->
<include file="$(find pr2_arm_navigation_actions)/launch/environment_server.launch"/>

<!-- load controllers -->
<include file="$(find pr2_arm_navigation_filtering)/launch/trajectory_filter.launch"/>

<!-- load ik -->
<include file="$(find pr2_arm_navigation_kinematics)/launch/left_arm_collision_free_ik.launch"/>
<include file="$(find pr2_arm_navigation_kinematics)/launch/right_arm_collision_free_ik.launch"/>

</launch>

when I launch it on the pr2 (versus sim) I get the following warnings:

  1. "Empty joint state map cache" (keeps getting printed at fast frequency)
  2. "Got joint state update but did not update some joints for more than 1s" (once in a while)

Then if I try to run some tasks such as positioning one arm in a certain configuration (http://ros.informatik.uni-freiburg.de/roswiki/move_arm%282f%29Tutorials%282f%29MoveArmPoseGoal.html) or moving the base (i.e. http://www.ros.org/wiki/pr2_controllers/Tutorials/Using%20the%20robot%20base%20controllers%20to%20drive%20the%20robot) the task does does not work and just hangs.

Google didn't help that much. Do you know what it could be the reason and how to fix it?

Thanks

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by tfoote
close date 2013-02-03 07:46:04

Comments

Can you post the output of "rostopic echo /joint_states"?
Martin Günther gravatar imageMartin Günther ( 2011-12-13 22:42:44 -0500 )edit