Ask Your Question
0

Using Webui...

asked 2011-12-03 16:22:12 -0500

Atom gravatar image

updated 2011-12-03 17:06:06 -0500

I have recently been trying to interface turtlebot with Webui packages to create some telepresence over a internet web browser. I was able to get everything installed and working, but I can only launch apps under localhost only and not through my external ip. I believe my network is configured properly through port forwarding. As I can load the gui from the internet and read some information about roscore. But I can only see nodes, and topics under localhost. Is this normal operation with Webui? I understand the stack maybe deprecated or no longer under development. But I was hoping to get some help on this issue. My main goal is to get a web interface similar to Roborealm's where I can control turtlebot and broadcast video over the internet. Any Ideas appreciated....

edit retag flag offensive close merge delete

Comments

Are you seeing any errors anywhere? In particular, is anything showing up in the apache logs?
Dan Lazewatsky gravatar image Dan Lazewatsky  ( 2011-12-04 07:31:49 -0500 )edit
Thanks for the reply dlaz.. I did notice some errors in apache logs but nothing related to the problems I was seeing. I actually figured out what my problem was, see my answer. I hope this helps anyone trying to utilize Webui...
Atom gravatar image Atom  ( 2011-12-05 15:06:28 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2011-12-05 15:22:38 -0500

Atom gravatar image

updated 2011-12-05 17:30:20 -0500

The problem I was encountering was due to admin privilege's associated with the ubuntu group user. I also have come to find out thanks to a helpful friend of mine ,Thanx Jay... that the apache server is some what secured and that admin privaleges are not given to non-local users. So we did some research and found a helpful command that sets the user {www-data} to admin status. Thus allowing me to launch apps from an external ip. I also understand that this may compromise my security on the server which is why it isnt a default setting to begin with. So to correct my initial issue.. First run roscore, webui.launch and type in terminal 'sudo adduser www-data admin ' then restart the server and possibly roscore and that should do the trick. Im not sure how this may or may not work for others using different versions of ubuntu but I'm using 10.10 and worked like a charm.

edit flag offensive delete link more

Comments

Also like to add in your routers configuration for port forwarding make sure you have ports 9090 and 8068 assigned to your computers ip.
Atom gravatar image Atom  ( 2011-12-06 08:27:19 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-12-03 16:22:12 -0500

Seen: 309 times

Last updated: Dec 05 '11