Ask Your Question
0

Openni_camera

asked 2011-12-02 00:28:21 -0500

apalomer gravatar image

Hi,

When I run the openni_camera node and try to see the image through a lan networks i keep seeing it as pictures not as video. I mean that it is relly slow. I think that maight be because the openni_manager launches a lot of topics.

In my case I don't want most of those topics, I just want the image. Is there any option to launch only the image, or only the parts that I want. For exemple the image and the depth frame?

Thanks!

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
3

answered 2011-12-02 08:28:03 -0500

Patrick Mihelich gravatar image

The OpenNI driver only publishes on topics that have subscribers. You don't pay for what you don't use.

It sounds like your network can't handle all the data, and many image messages are getting dropped. This is common when using wifi. You can test this by running

rostopic hz /camera/rgb/image_raw

on both the computer hooked up to the Kinect and your cross-network machine. The computer hosting the Kinect should see ~30 messages/second, while the other may see less if the network is inadequate.

If bandwidth is the limiting factor, it may help to use compressed versions of the image topics. See if you get better results from

rosrun image_view image_view image:=/camera/rgb/image_raw theora

which will compress the image stream through the Theora codec (note: you must have the image_transport_plugins stack installed on both ends). See image_transport for details.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-12-02 00:28:21 -0500

Seen: 459 times

Last updated: Dec 02 '11