Ask Your Question
0

OpenNI/rviz connection to Kinect failed

asked 2014-01-23 03:58:09 -0500

Rolias gravatar image

updated 2016-10-24 09:02:17 -0500

ngrennan gravatar image

Hey everyone,

I'm running Ubuntu 12.04, ros hydro, openni and now I'm trying desperately to connect my kinect to rviz. My aim is to realize a SLAM algorithm on my Eddie robot, therfore i use the guide of Dr. Rainer Hessmer: 2d SLAM with ROS and Kinect. I would give you the link, but i have to less karma..;-)

The first steps are easy, installing the ros and openni doesn't make any problems. But after the install process, neither rviz nor openni is able to locate the kinect: rviz says: No tf data. Actual error: Fixed Frame [openni_camera] does not exist.,openni says: no device connected (after using roslaunch openni_launch openni.launch to start the framework.).

Ubuntu itself connects with the kinect: lsusb displays the connections, so i think the drivers which come with openni are actually working.

What am I doing wrong? Any suggestions? Thanks for your help!!!

Robin

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2014-01-23 09:09:04 -0500

Athoesen gravatar image

Alright you should give a little bit more detail about your specific problems but I'm guessing these two links should help:

http://wiki.ros.org/openni_launch

http://wiki.ros.org/openni_launch/Tutorials/QuickStart

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-01-23 03:58:09 -0500

Seen: 319 times

Last updated: Jan 23 '14