Ask Your Question
0

gmapping pacakage Overlaying with catkin workspaces

asked 2014-01-22 03:12:36 -0500

bvbdort gravatar image

updated 2014-01-28 17:19:07 -0500

ngrennan gravatar image

Hi,

I have installed ROS groovy version. I want to do changes in gmapping.

Gmapping is using libararies from openslam_gmapping, So i have cloned slam_gmapping and openslam_gmapping separately and built them.

But when i run launch file to run gmapping , i am getting below error

ERROR: cannot launch node of type [gmapping/slam_gmapping]: can't locate node [slam_gmapping] in package [gmapping]

launch file :

<launch> <node pkg="gmapping" type="slam_gmapping" name="slam_gmapping" respawn="false" output="screen">   
  <param name="odom_frame" value="odom"/>
  <param name="map_update_interval" value="0.1"/>
  <param name="maxUrange" value="69"/>
  <param name="maxRange" value="71"/>
  <param name="sigma" value="0.05"/>
  <param name="kernelSize" value="1"/>
  <param name="lstep" value="0.05"/>
  <param name="astep" value="0.05"/>
  <param name="iterations" value="5"/>
  <param name="lsigma" value="0.075"/>
  <param name="ogain" value="3.0"/>
  <param name="lskip" value="0"/>
  <param name="srr" value="0.01"/>
  <param name="srt" value="0.02"/>
  <param name="str" value="0.01"/>
  <param name="stt" value="0.02"/>
  <param name="linearUpdate" value="0.2"/>
  <param name="angularUpdate" value="0.3"/>
  <param name="temporalUpdate" value="0.1"/>
  <param name="resampleThreshold" value="5"/>
  <param name="particles" value="10"/>
  <param name="xmin" value="-5.0"/>
  <param name="ymin" value="-5.0"/>
  <param name="xmax" value="5.0"/>
  <param name="ymax" value="5.0"/>
  <param name="delta" value="0.05"/>
  <param name="llsamplerange" value="0.01"/>
  <param name="llsamplestep" value="0.01"/>
  <param name="lasamplerange" value="0.005"/>
  <param name="lasamplestep" value="0.005"/>
  <remap from="scan" to="laserscan"/>
</node>
</launch>

How to do code changes to openslam_gmapping

thanks.

edit retag flag offensive close merge delete

Comments

Do you mean with "but it was from ros stack not the package which i cloned,did changes and built." that a copy of gmapping you installed with apt-get is being executed and not the copy you cloned from source?

BennyRe gravatar imageBennyRe ( 2014-01-22 04:25:31 -0500 )edit
bvbdort gravatar imagebvbdort ( 2014-01-23 03:36:06 -0500 )edit

If you get the error above I'm pretty sure you have NOT built it. Also IIRC the gmapping package does download gmapping itself during the build process.

dornhege gravatar imagedornhege ( 2014-01-23 03:39:38 -0500 )edit

@dornhege i have cloned and build the slam_gmapping cloned from https://github.com/ros-perception/slam_gmapping.git

bvbdort gravatar imagebvbdort ( 2014-01-23 03:46:07 -0500 )edit

Did you correctly overlay these two packages? Here's the tutorial: http://wiki.ros.org/catkin/Tutorials/workspace_overlaying

BennyRe gravatar imageBennyRe ( 2014-01-23 03:59:03 -0500 )edit

@BennyRe i followed as tutorial i was able to buid and roscd is working fine but when i run from "roslaunch gmapping slam_gmapping_pr2.launch" i am getting error as mentioned in question.

bvbdort gravatar imagebvbdort ( 2014-01-23 04:35:22 -0500 )edit
1

Does your binary exist? check <your catkin="" ws="">/devel/lib/gmapping

BennyRe gravatar imageBennyRe ( 2014-01-23 05:01:00 -0500 )edit

@BennyRe yes binary exists in /home/overlay_ws/slam_gmapping/devel/lib/gmapping

bvbdort gravatar imagebvbdort ( 2014-01-23 05:05:44 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
2

answered 2014-01-24 00:48:40 -0500

dornhege gravatar image

If you have two different workspaces sourcing either one will replace the other fully.

If you want both together you can either merge all packages in one workspace or overlay one workspace with another.

edit flag offensive delete link more

Comments

Thanks, it worked after putting slam_gmapping, openslam_gmapping in mypackage/src/ and overlay mypackage.

bvbdort gravatar imagebvbdort ( 2014-01-24 02:46:13 -0500 )edit

bvb, I want to do the same thing you are, but I am uncertain how to get setup the openslam_gmapping sources so they build and are recognized as a ROS package. will the "find_packag(catkin REQUIRED nav_msgs openslam_gmapping roscpp rostest tf)"in CMakeLists.txt just work?

gershon gravatar imagegershon ( 2014-01-29 08:18:55 -0500 )edit

@gershon i did git clone for gmapping and openslam_gmapping inside /src folder of my package. This tutorial is helpful.http://wiki.ros.org/catkin/Tutorials/workspace_overlaying

bvbdort gravatar imagebvbdort ( 2014-01-29 10:10:58 -0500 )edit

Aha! I see now. The only link to source from the slam_gmapping page takes me to an external site that lists the code in a svn repository. Now I think I see what you mean. I did find the openslam_gmapping source on git. Thanks!

gershon gravatar imagegershon ( 2014-01-29 13:24:57 -0500 )edit

@bvbdort Can you please provide some clarification? I am having the same problem, and the Workspace Overlay Tutorial isn't helping me. Thanks!

davidgitz gravatar imagedavidgitz ( 2015-05-14 21:29:54 -0500 )edit

@davidgitz can you tell me what is the exact problem.

bvbdort gravatar imagebvbdort ( 2015-05-15 02:47:46 -0500 )edit

@bvbdort I don't want to hijack this thread but I think my problem is identical. I have done a git clone for the slam_gmapping and openslam_gmapping and put in: ~/catkin_ws/src Then I did: source /opt/ros/groovy/setup.bash and source ~/catkin_ws/devel/setup.bash and get the same error as the OP.

davidgitz gravatar imagedavidgitz ( 2015-05-18 21:43:04 -0500 )edit
1

your procedure is correct, did you build, if yes check binaries in catkin_ws/devel/lib

bvbdort gravatar imagebvbdort ( 2015-05-18 23:06:59 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-01-22 03:12:36 -0500

Seen: 995 times

Last updated: Jan 24 '14