Ask Your Question
1

roslaunch openni_launch openni.launch Failed to set USB interface

asked 2014-01-22 01:17:45 -0500

acp gravatar image

updated 2014-01-28 17:19:07 -0500

ngrennan gravatar image

Dear all

I have installed

ros-hydro-openni-launch

And when I run the command:

roslaunch openni_launch openni.launch

I get the following error:

Image: PrimeSense/SensorV2/5.1.0.41: Failed to set USB interface!

And after running dmesg | tail

[19250.592329] usb 3-6:  New USB device found, idVendor=1d27, idProduct=0600

[19250.612487] usb 3-6: New USB device strings: Mfr=2, Product=1, SerialNumber=0

[19250.612496] usb 3-6: Product: PrimeSense Device

[19250.612502] usb 3-6: Manufacturer: PrimeSense

[19250.613072] usb 3-6: Not enough bandwidth for new device state.

[19250.613091] usb 3-6: can't set config #1, error -28

[21923.567674] usb 3-6: USB disconnect, device number 27

Does someone have a clue?

In advance thank you.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
2

answered 2014-01-22 01:23:28 -0500

ZdenekM gravatar image

updated 2014-01-22 01:48:59 -0500

I found two possible solutions:

  • sudo modprobe -r gspca_kinect as suggested here

  • or deactivating xHCI and EHCI Hand-off in the bios as suggested here

  • there is also some firmware update from Asus related to USB 3.0 problems
edit flag offensive delete link more

Comments

Thank you Zdenek, I solved the problem by disabling the USB3 in the Bios and enabling USB2. I will later on try the firmware from Asus.

acp gravatar imageacp ( 2014-01-22 20:30:39 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-01-22 01:17:45 -0500

Seen: 2,868 times

Last updated: Jan 22 '14