Ask Your Question
3

ros electric gpsd_client error

asked 2011-11-14 18:23:58 -0500

Chrimo gravatar image

updated 2011-11-15 01:09:05 -0500

joq gravatar image

Hi community,

currently gpsd_client did not work any more ;-

MockBot$ rosrun gpsd_client gpsd_client _port:=2947

netlib_connectsock() returns socket on fd 9
[ INFO] [1321344855.149877424]: GPSd opened
terminate called after throwing an instance of 'boost::exception_detail::clone_impl<boost::exception_detail::error_info_injector<boost::math::rounding_error> >'
  what():  Error in function boost::math::round<d>(d): Value nan can not be represented in the target integer type.
Abgebrochen

gpsd is running:

MockBot$ sudo lsof -i :2947
COMMAND  PID   USER   FD   TYPE DEVICE SIZE/OFF NODE NAME
gpsd    3466 nobody    4u  IPv4  93755      0t0  TCP localhost.localdomain:gpsd (LISTEN)
gpsd    3466 nobody    5u  IPv6  93756      0t0  TCP ros:gpsd (LISTEN)

I've updated ros-electric with apt-get to the last version...

Any idea ?

Cheers

Christian

edit retag flag offensive close merge delete

6 Answers

Sort by ยป oldest newest most voted
8

answered 2011-11-18 00:05:30 -0500

I got the same error when using an UBOX gps.. the problem was that the gps doesn't publish the time as requested by the gpsd_client.

To solve it you have to pass a parameter to disable the time from gps

here is the command line i use to start gpsd_client

$ rosrun gpsd_client gpsd_client _host:=localhost _port:=2947 _use_gps_time:=false

and it should work

Regards

Mario

edit flag offensive delete link more
1

answered 2011-11-20 23:03:25 -0500

Chrimo gravatar image

process[gpsd_client-7]: started with pid [1697]

:-)

New release from git and your suggestion _use_gps_time:=false works out of the box !!!

GREAT! Thanks and special greetings from Hamburg Cheers Christian

edit flag offensive delete link more

Comments

Please use the comment section instead of answering. The answers are not displayed in chronological order so it can get confusing. Thanks!

Thomas D gravatar image Thomas D  ( 2012-05-24 07:25:13 -0500 )edit
0

answered 2012-04-04 10:23:30 -0500

AeroTech gravatar image

updated 2012-04-04 10:23:54 -0500

I am having the same problem, except this fix does not work for me. I am still getting


netlib_connectsock() returns socket on fd 9 terminate called after throwing an instance of 'boost::exception_detail::clone_impl<boost::exception_detail::error_info_injector<boost::math::rounding_error> >' what(): Error in function boost::math::round<d>(d): Value nan can not be represented in the target integer type.

Aborted

when I use

rosrun gps_fixed gps_fixed _host:=localhost _use_gps_time:=false

to run.

does anybody have any other ideas?

edit flag offensive delete link more
0

answered 2012-05-24 06:04:07 -0500

rjgill gravatar image

Has anyone been able to fix this issue? I get the exact same problem running ros-electric on Ubuntu 11.10.

edit flag offensive delete link more
-1

answered 2011-11-20 22:59:08 -0500

Chrimo gravatar image

too fast... I found a newer version of gpsd_client at git :-) Checking this new version with your suggested params...

THX!!! Cheers Christian

edit flag offensive delete link more
-1

answered 2011-11-20 22:34:02 -0500

Chrimo gravatar image

Hi Mario,

thanks for your advice, but it didn't work for me ;-( Did gpsd_client support this value ? I cannot find anything at the source code...

Searching.... :-) Cheers Christian

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-11-14 18:23:58 -0500

Seen: 1,066 times

Last updated: May 24 '12