Ask Your Question
2

ros kinect roslaunch openni_launch openni.launch

asked 2011-11-13 20:26:56 -0500

acp gravatar image

updated 2016-10-24 09:01:45 -0500

ngrennan gravatar image

Hi to every body

I have installed ros on ubuntu 10.04 then I have installed kinect drivers following http://www.ros.org/wiki/openni_kinect

1.- I run roslaunch openni_launch openni.launch

I get the following errors:

Tried to advertise a service that is already advertised in this node [/camera/depth_registered/image_rect_raw/compressed/set_parameters]

Tried to advertise a service that is already advertised in this node [/camera/depth_registered/image_rect_raw/theora/set_parameters]

Unable to open camera calibration file [/home/acp/.ros/camera_info/rgb_A00361808210049A.yaml]

Unable to open camera calibration file [/home/acp/.ros/camera_info/depth_A00361808210049A.yaml]

then the system hangs in

Exiting onInitImpl()

I have no clue about these errors, any suggestion or solution will be appreciated.

Regards, Alfredo

edit retag flag offensive close merge delete

Comments

could you give more details about how you installed the drivers? When you run the node make sure its not running already. Pls post the commands and codes in "preformatted text". It makes things clear and easy to analyse.
karthik gravatar imagekarthik ( 2011-11-13 21:27:05 -0500 )edit
Have you tried visualizing the point cloud in rviz? The launch file just starts the driver, etc.. not the visualizer.
Ugo gravatar imageUgo ( 2011-11-13 23:51:25 -0500 )edit
well, how do you preformatted text :) yea I could open rviz, how do you visualize the point cloud with rviz?
acp gravatar imageacp ( 2011-11-17 17:50:38 -0500 )edit
select the correct fixed frame (camera_link for example), then add a point cloud 2 plugin and select the topic /camera/depth_registered/points or /camera/depth/points if you haven't checked the register point cloud in dynamic reconfigure.
Ugo gravatar imageUgo ( 2011-11-21 01:16:31 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2011-11-14 20:12:09 -0500

dinamex gravatar image

Hi Alfredo,

I got the same error msg with the new openni_launch file. But to get rid of the error massage for the calibration you should follow these instructions http://www.ros.org/wiki/openni_camera/calibration

after the calibration you will have the needed calibration files in the right folder. But I have no idea how to fix the advertising problem.

edit flag offensive delete link more

Comments

cool, I will try that, thanx :)
acp gravatar imageacp ( 2011-11-17 17:51:03 -0500 )edit
0

answered 2012-03-12 06:37:39 -0500

Hi acp,

I am getting exactly the same error. Could you please tell me how you solved it?

I saw : http://answers.ros.org/question/10990/problem-starting-openni-in-ros-electric and tried using : oslaunch openni_camera openni_node.launch

I was able to see the rgb data in rviz but it is very unstable. I changed Image topic from rgb to depth and it crashed. I got following errors:- terminate called after throwing an instance of 'openni_wrapper::OpenNIException' what(): virtual void openni_wrapper::OpenNIDevice::startDepthStream() @ /tmp/buildd/ros-electric-openni-kinect-0.3.4/debian/ros-electric-openni-kinect/opt/ros/electric/stacks/openni_kinect/openni_camera/src/openni_device.cpp @ 257 : starting depth stream failed. Reason: Xiron OS got an event timeout! [openni_node1-2] process has died [pid 11093, exit code -6]. log files: /home/nirala/.ros/log/1acd4b66-6c5d-11e1-b338-b8ac6f6bfba7/openni_node1-2*.log

When I restart it then I am getting the follwoing error:- openni_node: /usr/include/boost/smart_ptr/shared_ptr.hpp:412: boost::shared_ptr<t>::reference boost::shared_ptr<t>::operator() const [with T = xn::NodeInfo, boost::shared_ptr<t>::reference = xn::NodeInfo&]: Assertion `px != 0' failed. [openni_node1-2] process has died [pid 12086, exit code -6]. log files: /home/nirala/.ros/log/d289bd42-6c5e-11e1-96e9-b8ac6f6bfba7/openni_node1-2.log

Kindly help me out.

edit flag offensive delete link more

Comments

I am new to ROS and this is my first post. I wanted to add it as comment, but couldn't know how. After the post though I could see the comment option. Kindly also let me know, how to add comment.

aknirala gravatar imageaknirala ( 2012-03-12 06:46:55 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-11-13 20:26:56 -0500

Seen: 5,296 times

Last updated: Mar 12 '12