Ask Your Question
0

Planning Description Configuration Wizard not launching

asked 2011-11-11 08:49:23 -0500

robbie gravatar image

updated 2014-01-28 17:10:46 -0500

ngrennan gravatar image

In the process of doing the Planning Description Configuration Wizard tutorial I am running

roslaunch planning_environment planning_description_configuration_wizard.launch urdf_package:=planning_models urdf_path:=test_urdf/robot.xml

as per the instructions. However, I recieve the error:

/opt/ros/electric/stacks/arm_navigation/planning_environment/bin/planning_description_configuration_wizard: error while loading shared libraries: libvtkIO.so.5.4: cannot open shared object file: No such file or directory [planning_description_configuration_wizard-3] process has died [pid 12506, exit code 127]. log files: /home/robbie/.ros/log/742288a6-0cb4-11e1-a787-001ec936b097/planning_description_configuration_wizard-3*.log

I am running ROS Electric on Ubuntu 11.10. I have tried copying the libvtk 5.6 library files in /usr/lib to have the 5.4 extension, but this results in a symbol not found error. I also tried downloading the source for VTK 5.4, compiling it with shared libraries enabled, and copying the creating library files into /usr/lib, but this also resulted in an error.

I am new to ROS, so any help would be much appreciated.

edit retag flag offensive close merge delete

Comments

Please post your ROS_PACKAGE_PATH and how you have installed all packages. Also helpful would be an ldd of planning_description_configuration_wizard
tfoote gravatar image tfoote  ( 2011-11-17 10:52:10 -0500 )edit
That version of libvtk is the one from natty - did you install 11.04 debs on an 11.10 system?
egiljones gravatar image egiljones  ( 2011-11-17 10:59:15 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2011-11-18 16:45:49 -0500

robbie gravatar image

updated 2011-11-18 16:46:17 -0500

The problem was that I did not update /etc/apt/sources.list.d/ros-latest.list after upgrading. It appears to work now. Thank you for the help.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-11-11 08:49:23 -0500

Seen: 176 times

Last updated: Nov 18 '11