Ask Your Question
0

Package Dependency Problem [closed]

asked 2016-09-13 06:04:31 -0500

padygord gravatar image

I am trying to get code that worked on ROS Indigo / Ubuntu 14.04 to work on ROS Kinetic / Ubuntu 16.04. When I run the ros package through a launch file I get the error "Could not load library: libvtkCommon.so.5.10 no such file or directory". VTK is required by PCL Visualization, so if I do rosdep resolve libpcl-all-dev, I get libpcl-dev in the ubuntu repos, which depends on libvtk6-dev. But the file libvtkCommon.so.5.10 comes from package libvtk5.10 which clashes with libvtk6-dev. I am not sure how to fix this link/package error.

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by padygord
close date 2016-09-14 03:23:06.013985

1 Answer

Sort by ยป oldest newest most voted
0

answered 2016-09-13 07:45:35 -0500

padygord gravatar image

Ive fixed it now, it was a problem with the CMakeLists.txt in migrating from Indigo to Kinetic, I didnt have to link against libvtkCommon.so and libvtkFiltering.so any more.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2016-09-13 06:04:31 -0500

Seen: 219 times

Last updated: Sep 13 '16