Ask Your Question
0

rosserial_client does not include make_library.py

asked 2014-01-17 06:15:10 -0600

4LV4R0 gravatar image

updated 2016-10-24 09:10:51 -0600

ngrennan gravatar image

Good afternoon partners.

I've just installed this morning Rasbpian/Groovy on a second raspberry of mine.

When I follow the instructions to get "rosserial" on

http://wiki.ros.org/rosserial_arduino...

everything goes well. BUT :

When I arrive to the step Adding Custom Messages(Generating Message Header File) on

http://wiki.ros.org/rosserial_arduino...

and try to generate the header file invoking

rosrun rosserial_client make_library.py ~/sketchbook/libraries My_Package

I'm given : [rosrun] Couldn't find executable named make_library.py below /home/pi/catkin_ws/install/share/rosserial_client

Taking a look into ~/catkin_ws/install/share/rosserial_client/src I have only the "ros_lib" folder and the "rosserial_client" folder, wich includes "make_library.py and __init__.py", is missing.

Source : https://github.com/ros-drivers/rosser...

I don't know if it could be a forgetting updating repo or something. I just wanted to feedback it.

Thanks

EDIT 1 : I have done the next

cp -r ~/catkin_ws/src/rosserial/rosserial_client/src/rosserial_client/ /catkin_ws/install/share/rosserial_client/src/

Now I can execute rosrun rosserial_client make_library.py ~/sketchbook/libraries My_Package and to get the header file to my new message types.

I just wanted to share this with the community beacuse it seems that during the compiling of rosserial with catkin_make ... make_library.py is missing.

I hope this could help you in the futuro

Thanks for reading

EDIT 2: This solution does not work now. Now if I invoque "rosrun rosserial_client make_library.py ~/sketchbook/libraries My_Package", it seems that it does nothing because it does not create the header. I don´t know what can we do ..Thanks

edit retag flag offensive close merge delete

Comments

This looks like a bug in rosserial_client and should probably be reported against their bugtracker.

ahendrix gravatar imageahendrix ( 2014-02-13 11:46:28 -0600 )edit

Thanks ahendrix for your interest. The problem now is that when I type "rosrun rosserial_client make_library.py ~/sketchbook/libraries My_Package" it´s like nothing happens ... Where can i report this ?

4LV4R0 gravatar image4LV4R0 ( 2014-02-13 12:10:52 -0600 )edit

The issue tracker for rosserial is here: https://github.com/ros-drivers/rosserial/issues

ahendrix gravatar imageahendrix ( 2014-02-13 12:37:09 -0600 )edit

The same problem that nothing happens in hydro even though I downloaded the newest rosserial_client from the github.

luxifu1989 gravatar imageluxifu1989 ( 2014-02-13 20:42:04 -0600 )edit

I have not reported it yet. I´m reporting when I finished a class . Thanks to both of you.

4LV4R0 gravatar image4LV4R0 ( 2014-02-13 21:08:42 -0600 )edit
4LV4R0 gravatar image4LV4R0 ( 2014-02-13 23:50:03 -0600 )edit

2 Answers

Sort by » oldest newest most voted
1

answered 2014-02-14 07:57:50 -0600

fergs gravatar image

updated 2014-02-14 08:08:13 -0600

In groovy/hydro, things were updated so that A) each client has it's own make_libraries.py script (for instance rosserial_adruino is different from rosserial_embedded_linux, this allows us to set things like endianness and whether the platform supports Float64) B) all messages are generated at once for every package on your path. Therefore, you need to run:

rosrun rosserial_arduino make_libraries.py <sketckbook_output_folder>

This will generate messages for ALL installed packages. The Arduino IDE tutorial has been updated, but not the one you reference (I'll update it right now).

edit flag offensive delete link more

Comments

Thank you for reply. All works well now.

luxifu1989 gravatar imageluxifu1989 ( 2014-02-16 18:27:57 -0600 )edit

I´ve tried 5 minutes ago. It perfectly worked for us. Thanks you so much

4LV4R0 gravatar image4LV4R0 ( 2014-02-16 22:39:16 -0600 )edit

I still can't find it in Fuerte!

Anas Alhashimi gravatar imageAnas Alhashimi ( 2015-11-20 11:07:12 -0600 )edit
0

answered 2014-02-13 19:38:56 -0600

luxifu1989 gravatar image

I tried today, it worked under electric.

edit flag offensive delete link more

Comments

Does the header file of a custom message depend on the ROS version to work with a simple arduino code ? I mean we want to send into a publisher four proximity sensor values so, if the .h can be done with other version, could be possible to do it with other ROS distro?

4LV4R0 gravatar image4LV4R0 ( 2014-02-13 20:43:23 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2014-01-17 06:15:10 -0600

Seen: 2,615 times

Last updated: Feb 14 '14