Ask Your Question
0

Rosserial with ChipKit Max 32

asked 2011-11-10 19:21:04 -0500

Rathesan Ravendran gravatar image

updated 2014-01-28 17:10:45 -0500

ngrennan gravatar image

I'm trying to setup rosserial communication together with my ChipKit Max32 microcontroller.

When I try to compile I get this error:

Sketch_nov11a.cpp:7:17: fatal error: ros.h: No such file or directory compilation terminated.

I've tried to use the same code for my Arduino Mega 1280 board and it works fine. I have looked at the tutorial for rossial_client but wasn't able to make a code for the ChipKit board.

I am a new programmer but I think the problem is that the ChipKit board have PIC32 architecture instead of the traditional avr.

My system details :

So, my question is how to setup the rosserial_package for my ChipKit Max 32 board?

Any suggestions will be appreciated.

edit retag flag offensive close merge delete

3 Answers

Sort by ยป oldest newest most voted
0

answered 2011-11-15 08:41:28 -0500

fergs gravatar image

Please see the tutorial on adding new platforms. You have to create a hardware definition and then create ros.h as described so that you can use your hardware definition.

edit flag offensive delete link more
0

answered 2012-03-05 00:38:25 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

hey , I have the same problems but I didn't figure it out how to maek a hardware definition .

@Rathesan Ravendran did you managed to solve your problem?

edit flag offensive delete link more
0

answered 2012-06-05 20:32:23 -0500

Mr.EEPBppt gravatar image

Hi I also have a chipkit Max 32, it seems that the mpide creates a sketchbook directory elsewhere, so i copied the ros_lib directory and paste it on the sketchbook, it solved the problem of not such file or directory, but it generates an other, now when trying to compile the sketch i get . :error: macro "log" passed 2arguments, but takes just 1 any thoughts?

edit flag offensive delete link more

Comments

Please post new questions as a separate question, you can link to an existing question if needed.

fergs gravatar image fergs  ( 2012-06-11 23:53:19 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2011-11-10 19:21:04 -0500

Seen: 676 times

Last updated: Jun 05 '12