setup.bash in rosbuild workspace hangs

asked 2014-01-16 22:20:36 -0500

ZdenekM gravatar image

updated 2014-01-17 01:13:48 -0500

Hi all,

I'm using catkin and rosbuild workspaces (based on this tutorial). It was working fine but now I'm not able to source setup.bash from rosbuild workspace - probably after some upgrade. I even tried to remove all my workspaces and recreate them from scratch - still same. Source command hangs (doesn't return). Any idea?

If I do source ros_hydro/rosbuild_ws/setup.bash, then Ctrl+C (or source ros_hydro/rosbuild_ws/setup.sh which is not hanging - what's actually difference??) and env | grep ROS I'm getting:

ROS_ROOT=/opt/ros/hydro/share/ros
ROS_PACKAGE_PATH=/home/imaterna/ros_hydro/rosbuild_ws/but_env_percp:/opt/ros/hydro/share:/opt/ros/hydro/stacks:/home/imaterna/ros_hydro/catkin_ws/src
ROS_MASTER_URI=http://localhost:11311
ROS_WORKSPACE=/home/imaterna/ros_hydro/rosbuild_ws
ROS_TEST_RESULTS_DIR=/home/imaterna/ros_hydro/catkin_ws/build/test_results
ROSLISP_PACKAGE_DIRECTORIES=/home/imaterna/ros_hydro/catkin_ws/devel/share/common-lisp
ROS_DISTRO=hydro
ROS_ETC_DIR=/opt/ros/hydro/etc/ros

...which looks quite Ok. I can even roscd to my packages (but autocompletion doesn't work).

My system is Ubuntu 12.10 64 bit (3.5.0-45-generic), ROS Hydro. I'm using bash shell:

echo $SHELL
/bin/bash
edit retag flag offensive close merge delete

Comments

Could You be more specific on the system You're running on? More specifically, could You check an output of `echo $SHELL`, please? That **might** be different terminals (bash/dash/zsh/etc/etc...) compatibility issue.

Kamiccolo gravatar imageKamiccolo ( 2014-01-17 00:55:46 -0500 )edit

Sure, I forget to mention my system info.

ZdenekM gravatar imageZdenekM ( 2014-01-17 01:12:03 -0500 )edit

Hmmm... pretty weird. Actually, as far as I see, `setup.bash` works just like some kind of wrapper for `setup.sh` setting some catkin internal vars and launching `setup.sh`. Launching `bash -x ros_hydro/rosbuild_ws/setup.bash` should print the trace of commands being executed. That might help pinning an exact problem, the one which hangs up everything...

Kamiccolo gravatar imageKamiccolo ( 2014-01-17 02:01:53 -0500 )edit

For me it's also weird :) I've never had problems like this, grrr. Output of suggested command: http://pastebin.com/AvW47GZZ

ZdenekM gravatar imageZdenekM ( 2014-01-17 02:23:59 -0500 )edit

You could try removing the `devel` directory in your workspace. Running `catkin_make` inside the ws will automatically re-create the directory. I had a problem similar to this, and that was the only thing that worked for me. I didn't really spend much time digging into what was actually wrong.

jarvisschultz gravatar imagejarvisschultz ( 2014-01-17 05:41:02 -0500 )edit

Thanks for hint. But it didn't help. I even tried to remove all my workspaces and create them again. Still same :-(

ZdenekM gravatar imageZdenekM ( 2014-01-17 21:17:12 -0500 )edit

@ZdenekM, Sadly can't inspect Your `bash -x` output. Pastebin reports deleted content :(

Kamiccolo gravatar imageKamiccolo ( 2014-01-19 02:42:49 -0500 )edit

@Kamiccolo The system here somehow added < / p > at end of the link to pastebin - just remove it.

ZdenekM gravatar imageZdenekM ( 2014-01-19 19:49:43 -0500 )edit