Ask Your Question
1

workspaces broken with latest update (1/28/2013)?

asked 2013-01-28 14:25:14 -0500

updated 2013-01-29 05:23:03 -0500

I am using a rosbuild workspace overlayed on top of a catkin workspace according to this tutorial. I only source the rosbuild workspace setup.bash in my ~/.bashrc.

The release repository was updated today, and I upgraded my packages. It seems like my existing workspaces broke until I reinitialized them. I didn't think to capture the output before re-initializing.

Can someone confirm that this problem exists? Or did I just experience a weird hiccup?

Edit#1

Never mind, updates on a second machine worked correctly. This was a machine specific issue.

edit retag flag offensive close merge delete

Comments

I tried to upgrade my Precise Groovy development system this morning, but there were a long list of packages being kept back. Maybe that caused your problem.

joq gravatar imagejoq ( 2013-01-29 03:23:52 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2013-01-29 13:21:16 -0500

I suspect this bug report (which has been fixed since) was the cause. https://github.com/ros/catkin/issues/329

As far as I can tell, reinitializing the workspaces is sufficient.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2013-01-28 14:25:14 -0500

Seen: 82 times

Last updated: Jan 29 '13