Ask Your Question
0

Error installing gazebo from source

asked 2013-01-23 06:08:44 -0500

joseescobar60 gravatar image

Hello People,

i need to re-install my gazebo from source, in this moments i have created a workspace and there i run the folowing lines:

rosws set --svn simulator_gazebo https://code.ros.org/svn/ros-pkg/stacks/simulator_gazebo/tags/latest/

rosws update

everything goes ok until here, but when i run the rosmake i obtain this error:

jose@ubuntu:~/fuerte_workspace$ rosmake simulator_gazebo[ rosmake ] rosmake starting...                            
[ rosmake ] Packages requested are: ['simulator_gazebo']   
[ rosmake ] Logging to directory /home/jose/.ros/rosmake/rosmake_output-20130123-121606
[ rosmake ] Expanded args ['simulator_gazebo'] to:
['gazebo_plugins', 'gazebo_tools', 'gazebo', 'gazebo_worlds']
[rosmake-0] Starting >>> roslang [ make ]                  
[rosmake-1] Starting >>> urdf_interface [ make ]           
[rosmake-1] Finished <<< urdf_interface ROS_NOBUILD in package urdf_interface
[rosmake-0] Finished <<< roslang  No Makefile in package roslang
[rosmake-2] Starting >>> ivcon [ make ]                    
[rosmake-1] Starting >>> common_rosdeps [ make ]           
[rosmake-2] Finished <<< ivcon ROS_NOBUILD in package ivcon
[rosmake-0] Starting >>> roscpp [ make ]                   
[rosmake-3] Starting >>> colladadom [ make ]               
[rosmake-2] Starting >>> rosconsole [ make ]               
[rosmake-2] Finished <<< rosconsole  No Makefile in package rosconsole
[rosmake-1] Finished <<< common_rosdeps ROS_NOBUILD in package common_rosdeps
[rosmake-3] Finished <<< colladadom ROS_NOBUILD in package colladadom
[rosmake-1] Starting >>> ogre [ make ]                     
[rosmake-2] Starting >>> roslib [ make ]                   
[rosmake-0] Finished <<< roscpp  No Makefile in package roscpp
[rosmake-1] Finished <<< ogre ROS_NOBUILD in package ogre  
[rosmake-3] Starting >>> angles [ make ]                   
[rosmake-3] Finished <<< angles ROS_NOBUILD in package angles
[rosmake-2] Finished <<< roslib  No Makefile in package roslib
[rosmake-1] Starting >>> rosbuild [ make ]                 
[rosmake-1] Finished <<< rosbuild  No Makefile in package rosbuild
[rosmake-2] Starting >>> urdf_parser [ make ]              
[rosmake-2] Finished <<< urdf_parser ROS_NOBUILD in package urdf_parser
[rosmake-3] Starting >>> collada_parser [ make ]           
[rosmake-0] Starting >>> resource_retriever [ make ]       
[rosmake-1] Starting >>> opende [ make ]                   
[rosmake-3] Finished <<< collada_parser ROS_NOBUILD in package collada_parser
[rosmake-2] Starting >>> rostest [ make ]                  
[rosmake-3] Starting >>> urdf [ make ]                     
[rosmake-1] Finished <<< opende ROS_NOBUILD in package opende
[rosmake-1] Starting >>> parallel_quickstep [ make ]       
[rosmake-0] Finished <<< resource_retriever ROS_NOBUILD in package resource_retriever
[rosmake-3] Finished <<< urdf ROS_NOBUILD in package urdf  
[rosmake-2] Finished <<< rostest  No Makefile in package rostest
[rosmake-0] Starting >>> convex_decomposition [ make ]     
[rosmake-3] Starting >>> srdf [ make ]                     
[rosmake-1] Finished <<< parallel_quickstep ROS_NOBUILD in package parallel_quickstep
[rosmake-2] Starting >>> collada_urdf [ make ]             
[rosmake-2] Finished <<< collada_urdf ROS_NOBUILD in package collada_urdf
[rosmake-0] Finished <<< convex_decomposition ROS_NOBUILD in package convex_decomposition
[rosmake-3] Finished <<< srdf ROS_NOBUILD in package srdf  
[rosmake-1] Starting >>> xacro [ make ]                    
[rosmake-0] Starting >>> bullet [ make ]                   
[rosmake-3] Starting >>> geometry_msgs [ make ]            
[rosmake-2] Starting >>> ogre_tools [ make ]               
[rosmake-2] Finished <<< ogre_tools ROS_NOBUILD in package ogre_tools
[rosmake-2] Starting >>> std_srvs [ make ]                 
[rosmake-1] Finished <<< xacro ROS_NOBUILD in package xacro
[rosmake-1] Starting >>> rospy [ make ]                    
[rosmake-2] Finished <<< std_srvs  No Makefile in package std_srvs
[rosmake-0] Finished <<< bullet ROS_NOBUILD in package bullet
[rosmake-3] Finished <<< geometry_msgs  No Makefile in package geometry_msgs
[rosmake-3] Starting >>> sensor_msgs [ make ]              
[rosmake-1] Finished <<< rospy  No Makefile in package rospy
[rosmake-2] Starting >>> roswtf [ make ]                   
[rosmake-3] Finished <<< sensor_msgs  No Makefile in package sensor_msgs
[rosmake-1] Starting >>> message_filters [ make ]          
[rosmake-0] Starting >>> gazebo [ make ]                   
[rosmake-2] Finished <<< roswtf  No Makefile in package roswtf
[rosmake-1] Finished <<< message_filters  No Makefile in package message_filters
[rosmake-2] Starting >>> std_msgs [ make ]                 
[rosmake-3] Starting >>> gazebo_tools [ make ]             
[rosmake-1] Starting >>> tf [ make ]                       
[rosmake-1] Finished <<< tf ROS_NOBUILD in package tf      
[rosmake-1] Starting >>> nav_msgs [ make ]                 
[rosmake-2] Finished <<< std_msgs  No Makefile in package std_msgs
[rosmake-2] Starting >>> rosservice [ make ]               
[rosmake-1] Finished <<< nav_msgs  No Makefile in package nav_msgs
[rosmake-1] Starting >>> diagnostic_msgs [ make ]          
[rosmake-2] Finished <<< rosservice  No Makefile in package rosservice
[rosmake-1] Finished <<< diagnostic_msgs  No Makefile in package diagnostic_msgs
[rosmake-2] Starting >>> dynamic_reconfigure [ make ...
(more)
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2013-01-23 20:05:18 -0500

DamienJadeDuff gravatar image

The pertinent lines in your output are:

package/stack gazebo depends on non-existent package assimp

Since fuerte there is no ROS package assimp - it is a system dependency. You can see however that your manifest.xml wants it as a package: https://code.ros.org/svn/ros-pkg/stacks/simulator_gazebo/tags/latest/gazebo/manifest.xml

So you are getting the wrong version of gazebo.

I suggest getting the version for fuerte since that is what you are using. See the list of tags in the SVN repository here: https://code.ros.org/svn/ros-pkg/stacks/simulator_gazebo/tags/

The version for fuerte is 1.6.16 - this can be verified by looking at the rosinstall file for fuerte: http://packages.ros.org/cgi-bin/gen_rosinstall.py?rosdistro=fuerte&variant=desktop-full&overlay=no

There is also a tag for fuerte.

edit flag offensive delete link more

Comments

hello, tank you for your help, the idea is to install another version because the fuerte's version has a problem with the contact sensor, and i need another version, oldest or newer

joseescobar60 gravatar imagejoseescobar60 ( 2013-01-24 03:05:04 -0500 )edit

Do you know which versions do not have the contact sensor problem?

DamienJadeDuff gravatar imageDamienJadeDuff ( 2013-01-25 03:33:49 -0500 )edit

The above error can be fixed by removing the assimp dependency from the manifest.xml file in the package referenced (gazebo), assuming assimp is installed on your system. But that error would generally only be found for older versions of gazebo.

DamienJadeDuff gravatar imageDamienJadeDuff ( 2013-01-25 03:34:32 -0500 )edit

The general solution is to get the version of gazebo you want, attempt to compile and fix each error as it comes up. Try the closest version to Fuerte that you can get (preferably newer) first.

DamienJadeDuff gravatar imageDamienJadeDuff ( 2013-01-25 03:36:07 -0500 )edit

as i know the only version of gazebo with the contact sensors problem is the version of the ROS fuerte 1.6.16, i trying to install oanother version

joseescobar60 gravatar imagejoseescobar60 ( 2013-01-28 02:41:10 -0500 )edit

In that case since you know the problem is with 1.6.16 I suggest trying the next version after that (1.7.0) and then if that is buggy move on to later versions. Perhaps you have already posted your problems with making that work. If so, why don't you put a link to the question here.

DamienJadeDuff gravatar imageDamienJadeDuff ( 2013-01-28 09:14:38 -0500 )edit

that is what i did, but anyone version works, everyone fail!

joseescobar60 gravatar imagejoseescobar60 ( 2013-01-28 09:32:01 -0500 )edit

So what went wrong with 1.7.0 and up? The above errors seem to apply to 1.6.x series. Perhaps you need to start a new question with that error if you can't solve it. If you want to go with 1.6.x series, start by following my suggestion above for editing manifest.xml.

DamienJadeDuff gravatar imageDamienJadeDuff ( 2013-01-29 04:54:53 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-01-23 06:08:44 -0500

Seen: 432 times

Last updated: Jan 23 '13