Ask Your Question
2

Issues with sourcing and overlaying packages

asked 2014-01-16 06:43:48 -0600

Athoesen gravatar image

updated 2016-10-24 08:50:55 -0600

ngrennan gravatar image

I was trying to overlay a package on my ROS Hydro and in order to not type it in every time, I added it to the .bashrc so that it looks like this:

source /opt/ros/hydro/setup.bash
source /home/robot2/overlay_ws/devel/setup.bash

However, when I try to do a normal roslaunch:

roslaunch openni_launch openni.launch camera:=kinect_1 device_id:=1@0

on openni_launch it gives the following message:

multiple files named [openni.launch] in package [openni_launch]:
- /opt/ros/groovy/share/openni_launch/launch/openni.launch
- /opt/ros/hydro/share/openni_launch/launch/openni.launch
Please specify full path instead

The thing is, the only ROS package being sourced should be a camera_pose package. It doesn't have to do with the openni launching. I'm not sure why Groovy is being pulled in. I have it installed but not sourced or on package path at all.

edit retag flag offensive close merge delete

Comments

Can you update your question with the output of something like `env | grep ROS`? Without enough info, I can only assume that ROS_PACKAGE_PATH or else is messed up somehow.

130s gravatar image130s ( 2014-07-17 03:43:27 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2017-01-22 21:43:47 -0600

vinmean gravatar image

Clear the devel and build folder (along with hidden files) and do a catkin_make again. The devel/.catkin and build/.project files at times have details of other workspaces for some reason.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-01-16 06:43:48 -0600

Seen: 511 times

Last updated: Jan 22 '17