gmapping depth kinect nodelet cpu overloaded [closed]

asked 2014-01-16 03:09:23 -0500

acp gravatar image

updated 2016-10-24 08:35:38 -0500

ngrennan gravatar image

Dear all.

I am just trying to fuse laser with the xtion pro, the process is done in 2D, for that I use the fake kinect. I mean I convert 3D points to 2D points using the following script in a include file.

include file="$(find openni_launch)/launch/openni.launch"/> 

node pkg="nodelet" type="nodelet" name="kinect_laser" args="load 

depthimage_to_laserscan/DepthImageToLaserScanNodelet camera_nodelet_manager"> 

 <param name="scan_height" value="290"/> <!-- height in pixels -->

    <param name="scan_time" value="0.125"/>

    <param name="range_min" value="0.80"/>

    <param name="range_max" value="3.0"/>

    <param name="min_height" value=".10"/>

    <param name="max_height" value="2.0"/>

<remap from="image" to="/camera/depth/image_raw"/> 

<remap from="/scan" to="/scan_xtion"/>


When I run gmapping, the /base_link frame jump for a short period to the /map frame, and that gives me a crazy map.

The problem could be overload of the CPU. The nodelet gives me the following:


100.8   2.4     13:56.23  nodelet

and the load average: 6.84 with 2 cores

Is there anyway to reduce the CPU load due to the nodelet?

In advance thank you :)

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by tfoote
close date 2017-06-04 11:49:57.862006