Ask Your Question
0

Kinect can't be connected to my netbook

asked 2011-11-07 17:06:05 -0600

LG_turtlebot gravatar image

updated 2011-11-16 09:07:22 -0600

tfoote gravatar image

I'm using Ubuntu10.10. Following the diamondback installation instruction, I installed the ros-diamondback-turtlebot-robot,and finished turtlebot setup,networking setup,environment setup. There was nothing wrong, and I thought it's OK to connect the kinect.

However, when I tried roslaunch openni_camera openni_node.launch,it presented that

[ INFO] [1320732062.736897541]: [/openni_node1] No devices connected.... waiting for devices to be connected

Then I installed openni_kinect according to http://www.ros.org/wiki/openni_kinect, I got the same result.The light of kinect was twinkling,It didn't work, either. I sincerely wish someone could give me some suggestions,thanks a lot.

edit retag flag offensive close merge delete

Comments

Please edit your question and copy-paste in the output from openni_node.launch.
Patrick Mihelich gravatar imagePatrick Mihelich ( 2011-11-07 17:17:22 -0600 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2011-11-16 09:09:11 -0600

tfoote gravatar image

Please follow the TurtleBot Tutorials you need to make sure the breakers are turned on for the Kinect.

edit flag offensive delete link more

Comments

I have solved my problems,thank you all the same.
LG_turtlebot gravatar imageLG_turtlebot ( 2011-11-23 12:58:55 -0600 )edit
0

answered 2011-11-16 12:06:12 -0600

fergs gravatar image

You should use "roslaunch turtlebot_bringup kinect.launch", which will also set the breakers, remap the TF frames correctly and internally start the openni stuff.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-11-07 17:06:05 -0600

Seen: 297 times

Last updated: Nov 16 '11