Ask Your Question
1

Kinect: could not turn on frame synchronization [closed]

asked 2011-11-02 00:38:45 -0500

Ugo gravatar image

updated 2016-10-24 08:33:47 -0500

ngrennan gravatar image

When trying to view the colored point cloud on the kinect, I get this error:

terminate called after throwing an instance of 'openni_wrapper::OpenNIException'
  what():  virtual void openni_wrapper::OpenNIDevice::setSynchronization(bool) @     /code/ros_electric/perception_pcl/pcl/build/pcl/io/src/openni_camera/openni_device.cpp @ 490 : could not turn on frame synchronization. Reason: Device Protocol: Bad Parameter sent!

I'm able to visualize the /camera/depth/points in rviz.

Here is a screenshot of rviz and dynamic reconfigure: C:\fakepath\kinect.png

I'm running ros electric installed on debian squeeze 64bits. The full log is available here.

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by tfoote
close date 2013-07-23 05:51:11

Comments

+1 Also having this problem.

hauptmech gravatar image hauptmech  ( 2012-02-23 03:40:52 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2012-01-30 02:01:48 -0500

COS gravatar image

+1. I'm having the same issue. Does anyone have any ideas why/where this issue is coming from or how to solve it?

edit flag offensive delete link more

Question Tools

Stats

Asked: 2011-11-02 00:38:45 -0500

Seen: 352 times

Last updated: Jan 30 '12