Ask Your Question
2

Can't Link to liborocos-kdl.so.1.1

asked 2014-01-09 04:19:14 -0500

David Lu gravatar image

I can't run robot_state_publisher, installed on Hydro from debians. I get the following error message.

/opt/ros/hydro/lib/robot_state_publisher/robot_state_publisher: error while loading shared libraries: liborocos-kdl.so.1.1: cannot open shared object file: No such file or directory

Versions:

> dpkg -s ros-hydro-robot-state-publisher | grep 'Version'
Version: 1.9.10-0precise-20131228-0321-+0000
> dpkg -s ros-hydro-orocos-kdl | grep 'Version'
Version: 1.2.1-0precise-20131209-0906-+0000
edit retag flag offensive close merge delete

Comments

It appears 1.1 is for Groovy while 1.2 is for Hydro. I'm currently getting the same problem. Although both Groovy and Hydro are installed on this computer (shared lab) I know Hydro was sourced during my entire time doing this. https://groups.google.com/forum/#!topic/moveit-users/KS6fCrztt_0

Athoesen gravatar image Athoesen  ( 2014-03-21 08:08:33 -0500 )edit

3 Answers

Sort by ยป oldest newest most voted
0

answered 2014-01-11 08:22:19 -0500

David Lu gravatar image

Clean remove and then reinstall. Bah.

edit flag offensive delete link more

Comments

Is this how you solved it?

Athoesen gravatar image Athoesen  ( 2014-03-21 08:08:47 -0500 )edit
0

answered 2014-07-23 05:29:55 -0500

Yesterday, I updated the ROS packages in Hydro, and also I found the same problems, i.e. my controller cannot find liborocos-kdl.so.1.2.

I checked the libraries and I don't have the liborocos-kdl.so.1.2, in contrast I have liborocos-kdl.so and liborocos-kdl.so.1.3.

In my case the solution was to recompile my controller.

edit flag offensive delete link more

Comments

I've reported this as a bug against the orocos_kdl issue tracker: https://github.com/orocos/orocos_kinematics_dynamics/issues/30

ahendrix gravatar image ahendrix  ( 2014-07-24 02:50:30 -0500 )edit
0

answered 2014-01-09 09:49:51 -0500

130s gravatar image

Though not an answer, my logbook says that I had the same error last month (Dec 2013) with:

$ find /opt/ros -name 'liborocos-kdl*'
/opt/ros/hydro/lib/liborocos-kdl.so.1.2
/opt/ros/hydro/lib/liborocos-kdl.so.1.2.0
/opt/ros/hydro/lib/liborocos-kdl.so
/opt/ros/hydro/share/doc/liborocos-kdl

Now (1/9/2013) the error is gone with:

$ dpkg -s ros-hydro-orocos-kdl | grep 'Version'
Version: 1.2.1-0raring-20131209-0907-+0000
$ dpkg -s ros-hydro-robot-state-publisher | grep 'Version'
Version: 1.9.10-0raring-20131228-0425-+0000
$ find /opt/ros/hydro -iname 'liborocos*'
/opt/ros/hydro/lib/liborocos-kdl.so.1.2.1
/opt/ros/hydro/lib/liborocos-kdl.so.1.2
/opt/ros/hydro/lib/liborocos-bfl.so
/opt/ros/hydro/lib/liborocos-kdl.so
/opt/ros/hydro/share/doc/liborocos-kdl

I noticed that the version of liborocos-kdl.so* is different.

edit flag offensive delete link more

Comments

So it looks like we have the same setup, except I have precise instead of raring, and my system doesn't have liborocos-bfl.so. Does rosrun robot_state_publisher robot_state_publisher work for you?

David Lu gravatar image David Lu  ( 2014-01-10 06:06:28 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2014-01-09 04:19:14 -0500

Seen: 1,580 times

Last updated: Jan 11 '14