Ask Your Question
0

openni detecting device only in debug mode

asked 2011-10-17 02:45:17 -0500

Guido gravatar image

updated 2016-10-24 09:05:11 -0500

ngrennan gravatar image

Hi all,

I'm trying to run the openni_node.launch file on a PR2 with ubuntu lucid and diamondback. When starting the launch file with "debug=true" the kinect is detected correctly and I can visualize its output in rviz. However when starting the .launch with "debug=false", the node can't find the device.

The main difference with debug is that it launchs the node on a separate xterm. As far as I have seen, no environement variable is different in the xterm.

Someone has any idea ?

Guido

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2011-10-17 23:03:23 -0500

Guido gravatar image

Found out! This was due to another install of openni which was messing things up. Removed it, now it works.

Guido

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-10-17 02:45:17 -0500

Seen: 224 times

Last updated: Oct 17 '11