Ask Your Question
3

Cannot install ROS Hydro on Ubuntu 12.04

asked 2014-01-07 05:48:10 -0600

pmolina gravatar image

updated 2014-01-28 17:07:33 -0600

ngrennan gravatar image

Hi,

I am having a problem installing ROS Hydro on Ubuntu 12.04. The problem appears to be related to Openni/PCL binaries.

I am tyring to install ros-hydro-desktop. I have a x64 machine (might be the problem)

I used to have ROS Fuerte installed, but completely removed it. Steps taken:

sudo apt-get remove ros-fuerte-ros
sudo apt-get autoremove

I also update to the the distribution.

sudo apt-get dist-upgrade

When I try to install ROS hydro

 sudo apt-get install ros-hydro-desktop

I get the following response

The following packages have unmet dependencies:
ros-hydro-desktop : Depends: ros-hydro-viz but it is not going to be installed

Digging deeper into this leads to the following problem

ps-engine : Depends: openni-dev (>= 1.5.2.23~precise)

However, when trying to install "openni-dev", I get the following version installed:

Get:1 <a href="http://packages.ros.org/ros/ubuntu/">http://packages.ros.org/ros/ubuntu/</a> precise/main openni-dev amd64 1.3.2.1-4+precise2

They are clearly different versions of this package. I tried going to openni but this did not solve the problem.

I followed the installation instruction from the wiki (added deb http://packages.ros.org/ros/ubuntu precise main to /etc/apt/sources.list.d/ros-latest.list)

These are the threads I have been reading that are related to this problem but do not offer a direct solution

link1

link2

link3

Any feedback/ideas will be greatly appreciated. I have spent several hours on this and not getting closer :S

edit retag flag offensive close merge delete

Comments

This is an actual current problem. I still do not quite understand the position of ROS support on this. Check this very interested thread this is still ongoing.... http://www.pcl-users.org/PCL-installation-unmet-dependency-problem-td4030129.html

pmolina gravatar image pmolina  ( 2014-01-07 11:13:01 -0600 )edit

3 Answers

Sort by ยป oldest newest most voted
10

answered 2014-02-20 08:33:23 -0600

sebsch gravatar image

It looks like you might have added jochen sprickerhof's ppa for PCL, which interferes with hydro.

Removing it with the following command solved the problem for me:

sudo ppa-purge ppa:v-launchpad-jochen-sprickerhof-de/pcl
edit flag offensive delete link more

Comments

Thank you very much! You are a savior! This solves most of the problems - I can now install all openni stuff without problems. I have no idea why I had that on my ppas (guess better be careful what is on my ppas from now on)

pmolina gravatar image pmolina  ( 2014-06-07 14:01:08 -0600 )edit

Hero of the day. Would never had figured this out myself (busy 3 hours trying to install Hydro besides Groovy)

edward gravatar image edward  ( 2014-07-16 06:12:50 -0600 )edit

Precisely, this had been a common occurance for a long time and many other workaround get you stuck somewhere in the future, like installing turtlebot etc on hydro. Thanks for the proper fix.

Adnan Munawar gravatar image Adnan Munawar  ( 2014-11-04 14:02:24 -0600 )edit
1

answered 2014-01-08 04:02:33 -0600

pmolina gravatar image

I finally fixed this problem. I still do not think this is a solution, but so far it has not given me any trouble.

The problem is certainly rooted on the version of openni-dev package. I have no idea why the version currently online is 1.3.2 ...either way, this causes the package "ps-engine" to fail to install since it requires openni-dev 1.5.4 or later.

However, I installed aptitude and installed the openni-dev 1.3.2 and forced an install of an old version of ps-engine (5.2)... this however appears to play well with the PCL drivers and hence with the rest of ROS. I have however not tested this functionality, so I might run into other problems later.

Please read this thread for a full description of this: http://www.pcl-users.org/PCL-installation-unmet-dependency-problem-td4030129.html

Final commands used:

sudo aptitude install ps-engine

This will ask if it is OK to install the old version of ps-engine with the old openni-dev package (1.3) - press Y on this question. After this

 sudo apt-get install ros-hydro-desktop

Will complete without major problems.

I hope this helps other people with this problem.

Thanks!

edit flag offensive delete link more

Comments

Just a clarification: After "sudo aptitude install ps-engine" first option will be to not install ps-engine. It should be rejected with "n" and then the next option will be to install older version of ps-engine which should be accepted.

Vikas gravatar image Vikas  ( 2014-01-22 09:03:14 -0600 )edit
0

answered 2014-01-07 06:51:32 -0600

Athoesen gravatar image

I'm assuming you're using the instructions here: http://wiki.ros.org/hydro/Installation/Ubuntu

Have you tried installing the full package with the sudo apt-get install ros-hydro-desktop-full command instead of just sudo apt-get install ros-hydro-desktop? You say the problem appears related to PCL/Openni and if I'm not mistaken those might fall under the "2D/3D simulators, navigation and 2D/3D perception" category that this installation includes. Hope this helps.

edit flag offensive delete link more

Comments

Thank you for your response. Yes, I did followed the installation instructions on the site you specified (which is why I added http://packages.ros.org/ros/ubuntu/ precise/main to the source.list files) When I run the sudo apt-get install ros-hydro-desktop-full I get the following answer The following packages have unmet dependencies: ros-hydro-desktop-full : Depends: ros-hydro-desktop but it is not going to be installed Depends: ros-hydro-mobile but it is not going to be installed Depends: ros-hydro-perception but it is not going to be installed Depends: ros-hydro-simulators but it is not going to be installed The problem is still present with the OpenNI or the PCL libraries. I have tried to remove anything related to fuerte or openni. I think the problem is on the server provided by ROS. It has an older openni library and it should be updated.

pmolina gravatar image pmolina  ( 2014-01-07 09:59:15 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-01-07 05:48:10 -0600

Seen: 3,223 times

Last updated: Feb 20 '14