Ask Your Question
1

Slow observation buffer update warnings in move_base

asked 2011-10-06 13:05:20 -0500

xylo gravatar image

updated 2011-10-07 06:31:53 -0500

Hello,

I'm using a sick laser (lms-200) and a kinect camera as my sensors, mounted on a pioneer 3-at. I'm running ros diamondback on ubuntu 10.10, running gmapping with the nav stack.

I know from rostopic that the laser is publishing scans at around 10hz, however, I keep getting such warnings from move_base.

[ WARN] [1317944137.717114373]: The /scan observation buffer has not been updated for 5.18 seconds, and it should be updated every 5.00 seconds.

[ WARN] [1317944137.917127486]: The /scan observation buffer has not been updated for 5.38 seconds, and it should be updated every 5.00 seconds.

[ WARN] [1317944138.117128035]: The /scan observation buffer has not been updated for 5.58 seconds, and it should be updated every 5.00 seconds.

[ WARN] [1317944138.317100694]: The /scan observation buffer has not been updated for 5.78 seconds, and it should be updated every 5.00 seconds.

[ WARN] [1317944138.581264407]: Map update loop missed its desired rate of 1.0000Hz... the loop actually took 4.9738 seconds

Why does it take so long for the scan msg to register with move_base? Is it related to the slow map update warning at the bottom? The result is that it takes minutes to plan any simple path. Any help would be greatly appreciated! Thanks!

edit retag flag offensive close merge delete

Comments

What model of Sick scanner are you using?
DimitriProsser gravatar image DimitriProsser  ( 2011-10-07 02:15:17 -0500 )edit
It's sick lms-200.
xylo gravatar image xylo  ( 2011-10-07 06:20:59 -0500 )edit
What does the system load look like on the machine you're trying to use to run the navigation stack? If its high, you might consider turning down the controller and map update frequencies.
eitan gravatar image eitan  ( 2011-10-07 07:12:02 -0500 )edit
The system load's high when running gmapping and navigation, even when I turn down both the controller and map update frequencies to 1. When I run nav with a static map (eg. amcl), the system load drops significantly and nav functions fine. Any other ways of reducing load to run gmapping and nav?
xylo gravatar image xylo  ( 2011-10-07 08:26:22 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
2

answered 2011-12-21 00:32:59 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

Based on the comments above from @eitan and @xylo. The problem was that the computer was being overloaded by the navigation stack trying to run too fast. The solution was to turn down the update rates for the controller and update frequency. More details of parameters can be found on the navagation tuning guide

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-10-06 13:05:20 -0500

Seen: 1,997 times

Last updated: Dec 21 '11