Ask Your Question
0

roslaunch not working during tutorial (rosversion?)

asked 2014-01-01 18:50:28 -0600

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

When doing the roslaunch tutorial I was suppose to use this command:

roslaunch beginner_tutorials turtlemimic.launch

I get an error which prevents me from continuing the tutorial and I've set the ROS_PACKAGE_PATH to include the catkin_ws. (also am I suppose to add the path of the catkin or the rospackage). Anyways the error I get is:

WARNING: unable to configure logging. No log files will be generated
Checking log directory for disk usage. This may take awhile.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.

Invalid <param> tag: Cannot load command parameter [rosversion]: command [rosversion roslaunch] returned with code [1]. 

Param xml is <param command="rosversion roslaunch" name="rosversion"/>

Any help on this would be great as I am trying to learn ROS for the AUV we are making and I can't find anything related to this online.

Thanks

EDIT: Using ROS Hydro on Ubuntu 12.04

edit retag flag offensive close merge delete

Comments

Can you run `rosversion roslaunch` ? Is this an installation from debs or from source?

ahendrix gravatar imageahendrix ( 2014-01-02 13:04:53 -0600 )edit

I have the same error when following the tutorial. When I run 'rosversion roslaunch' the version is 1.9.50.

h iman gravatar imageh iman ( 2014-02-25 22:08:46 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2014-02-25 23:41:24 -0600

h iman gravatar image

updated 2014-02-26 23:19:44 -0600

@capa_matrix I had the same problem too and it was due to: (1) my workspace was not added to the ROS_PACKAGE_PATH or (2) I had change the variable ROS_PACKAGE_PATH to only ~/catkin_ws or elsewhere

Try this:

$ export ROS_PACKAGE_PATH=~/catkin_ws:$ROS_PACKAGE_PATH
$ echo $ROS_PACKAGE_PATH

if you get

 /YOUR_DIRECTORY/catkin_ws:/opt/ros/groovy/share:/opt/ros/groovy/stacks

then launch your .launch file

$ roslaunch beginner_tutorials turtlemimic.launch
edit flag offensive delete link more

Comments

You should never need to manually extend your package path for catkin packages. Just make sure to build the workspace and afterwards source the generated setup file.

Dirk Thomas gravatar imageDirk Thomas ( 2014-02-26 04:33:01 -0600 )edit

Thank you @Dirk Thomas. Does this means that I need to source the setup file in devel folder each time I need to work on a particular package?

h iman gravatar imageh iman ( 2014-02-26 23:17:53 -0600 )edit

Whenever you want to use stuff from a catkin workspace you have to source its setup file since it defines various variables necessary to find packages, plugins, binaries, libraries etc.

Dirk Thomas gravatar imageDirk Thomas ( 2014-02-27 05:25:48 -0600 )edit

Is there anyway to source the setup file automatically when I run roscore? Or is it not a good practice to do so?

h iman gravatar imageh iman ( 2014-02-27 06:07:07 -0600 )edit

If you haven't source any setup file you won't even be able to run roscore because it will not be on your path.

Dirk Thomas gravatar imageDirk Thomas ( 2014-02-27 06:24:16 -0600 )edit

You can source whatever setup file you like in your bashrc file. It is personal preference if you would like to do so. Since I have numerous workspace I just source them manually or via an alias.

Dirk Thomas gravatar imageDirk Thomas ( 2014-02-27 06:25:13 -0600 )edit

I see. Thanks so much Dirk.

h iman gravatar imageh iman ( 2014-02-27 06:53:05 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-01-01 18:50:28 -0600

Seen: 2,220 times

Last updated: Feb 26 '14