ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

Not able to find executables by using rosrun

asked 2013-12-30 23:24:39 -0500

Anand gravatar image

I am following the tutorials and created the files named talker.cpp and listner.cpp according to tutorial 11 and also used rosedit to edit CMakeLists.txt.

But i am not able to find the executables in bin.

also $rosrun beginner_tutorials talker is not working.

the error is: could not find executable named talker below /home/anand/fuerte_workspace/sandbox/beginner_tutorials

i have tried using rospack profile but was not useful.

I am new to ROS...please help as soon as possible.

I am using ros fuerte with rosbuild method in ubuntu 12.04 installed in virtualbox.

edit retag flag offensive close merge delete

3 Answers

Sort by ยป oldest newest most voted

answered 2013-12-30 23:56:08 -0500

Anand gravatar image

Thanks a lot for replying. The problem is solved now. i forgot to put '}' at the end of talker.cpp due to which rosmake was giving failure error.

edit flag offensive delete link more

answered 2013-12-30 23:46:44 -0500

gvdhoorn gravatar image

Have you remembered to build your package? Ie:

$ rosmake PKG_NAME
edit flag offensive delete link more


Please accept this answer so others don't spend time trying to help you solve a solved problem.

tfoote gravatar image tfoote  ( 2013-12-31 06:28:22 -0500 )edit

answered 2014-01-04 11:13:37 -0500

Kellya gravatar image

I have same problem too.

edit flag offensive delete link more


Hello, did you see the answer posted above? Also for the future, please don't post an "answer" to a question which doesnt contain an answer, you can use comments for that.

Tim Sweet gravatar image Tim Sweet  ( 2014-01-06 19:39:12 -0500 )edit

Question Tools


Asked: 2013-12-30 23:24:39 -0500

Seen: 472 times

Last updated: Jan 04 '14