ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question
0

3dsensor.launch doesn't work on hydro

asked 2013-12-18 05:35:26 -0600

SHPOWER gravatar image

updated 2016-10-24 08:35:35 -0600

ngrennan gravatar image

Hey all,

I am trying to run 3dsensor.launch file on hydro without any success. the strange thing is that the follower demo which uses 3dsensor.launch file is working good. What can be the problem? How can I fix this?

Thanks in advance.

edit retag flag offensive close merge delete

Comments

1

Please add more details to "tried without success". With the given information I am unable to help you.

bit-pirate gravatar image bit-pirate  ( 2013-12-18 21:25:05 -0600 )edit

Sorry I am working with turtlebot-2. my problem was that when I run the 3dsensor.launch to activate the kinect I coudn't get a DepthCloud data. I found the reason. I changed the argument (in 3dsensor.launch file) "depth_registration" to be "false" and that worked. I couldn’t see a "/scan" topic either. I still have a question. What does the depth_registration parameter do?

SHPOWER gravatar image SHPOWER  ( 2013-12-21 05:02:39 -0600 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2014-01-09 00:29:18 -0600

nsprague gravatar image

The issue is discussed here: http://answers.ros.org/question/112391/nothing-published-to-scan-under-hydro/ . I've submitted an issue to the github repository here: https://github.com/turtlebot/turtlebot/issues/123

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2013-12-18 05:35:26 -0600

Seen: 407 times

Last updated: Jan 08 '14