Ask Your Question
1

Android / Rocon_app_manager pairing error

asked 2013-12-13 03:13:01 -0600

The Fonz gravatar image

updated 2014-01-28 17:18:50 -0600

ngrennan gravatar image

When trying to pair an Android device with the Rocon_app_manager as per [1], the 'Robot Remocon' Android app does find the robot when pressing 'Add a robot > Scan the local network', but when pressing 'select' it tries to connect but displays an error:

org.ros.exception.RosRuntimeException: timed out waiting for a gateway_info publication

I tried on different networks (university-wide and at home through a local router) and two different pc's and android devices. There is at least some communication as there's a different error when the rocon_app_platform hasn't been started on the pc.

I tried to look up where this error originates but I am quite hopeless. Does anyone have an idea of how to solve this?


[1] wiki.ros.org/rocon_app_manager/Tutorials/hydro/Pairing%20with%20Androids

edit retag flag offensive close merge delete

Comments

Any chance that some of the problems here are due to the fact that you are using android devices that have multiple interfaces? You can diagnose by checking rostopic list and rosservice list to see if the connections are there. rostopic info on an android topic will show strange ip's.

Daniel Stonier gravatar imageDaniel Stonier ( 2014-06-29 08:38:25 -0600 )edit

This error is quite vague sorry....we have simplified communications hugely getting ready for indigo with better error feedback (yet to be released though).

Daniel Stonier gravatar imageDaniel Stonier ( 2014-06-29 08:39:51 -0600 )edit

4 Answers

Sort by ยป oldest newest most voted
2

answered 2013-12-16 14:54:49 -0600

Daniel Stonier gravatar image

I think probably your ROS_IP/ROS_HOSTNAME/ROS_MASTER_URI are not correctly set on the turtlebot for multi-device-pc communication. Some information on the roswiki and the turtlebot wiki.

The 'dumb' error message unfortunately is a late hydro regression I have yet to fix - it used to actually provide a hint to make sure you have your ROS_IP/ROS_HOSTNAME set.

edit flag offensive delete link more

Comments

You're right - setting ROS_IP and ROS_HOSTNAME in .bashrc works, per the instructions in the turtlebot wiki. Still not very stable, sometimes it connects, sometimes on retry, sometimes on app restart.

The Fonz gravatar imageThe Fonz ( 2014-01-17 02:15:12 -0600 )edit

Still quite beta, occasionally state gets confused if something goes awry. We're working hard to upgrade/stabilise the android environment better for igloo.

Daniel Stonier gravatar imageDaniel Stonier ( 2014-01-19 00:50:20 -0600 )edit
1

answered 2013-12-23 00:24:03 -0600

Johannes gravatar image

updated 2014-01-06 23:08:55 -0600

Hello, somehow I do face the same problems. In some networks there is not a problem at all to connect with the android app to the master, but in others I get the error mentioned above. So fare I just could connect sucessfully when creating a network with my android phone where I connected the ROS master and the tablet I'm using. In all my test scenarios the ROS master had set the ROS_IP correct. I used our university WLAN (did not work) and a dedicated WLAN network with a private network (did also not work).

Is there any special need the network has to fullfill?

Best Wishes Johannes

edit flag offensive delete link more

Comments

None that I can think of, but it may well be that we just haven't come across such a network. Logcats would be the next immediate step, but if they don't have enough information, it's down to debugging internals of rosjava.

Daniel Stonier gravatar imageDaniel Stonier ( 2014-01-14 00:02:50 -0600 )edit

Really need to identify what is different between the networks where you have success and where you didn't. I could perhaps reproduce the problem here then and debug.

Daniel Stonier gravatar imageDaniel Stonier ( 2014-01-14 00:03:11 -0600 )edit
0

answered 2014-01-08 19:41:49 -0600

Unipower123 gravatar image

updated 2014-01-08 19:42:31 -0600

In Europe and America,Dhgate is very famous. So maybe you can look for the correct answer by Dhgate

edit flag offensive delete link more
0

answered 2014-06-25 20:40:40 -0600

syaz nyp fyp gravatar image

hi all. is there a follow up to this question? I'm encountering the same problem now. i did set my ROS_IP/ROS_HOSTNAME/ROS_MASTER_URI on the turtlebot for multi-device-pc communication, as what Daniel said. the remocon app did found my turtlebot under "scan local network" but it was unable to access it and it shows:

org.ros.exception.RosRuntimeException: timed out waiting for a gateway_info publication

any help will be greatly appreciated. thanks in advance guys.

edit flag offensive delete link more

Comments

issue solved.

syaz nyp fyp gravatar imagesyaz nyp fyp ( 2014-07-10 00:21:59 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2013-12-13 03:13:01 -0600

Seen: 1,119 times

Last updated: Jun 25 '14