Ask Your Question
0

asctec_drivers and mav_tools Build errors on Ubuntu 11.04 running ROS

asked 2011-07-21 23:19:14 -0500

william nguatem gravatar image

updated 2011-09-02 11:10:34 -0500

kwc gravatar image

For our pelican running ROS on Ubuntu 11.04, I've got similar errors from building both asctec_drivers and mav_tools from git cloned versions of both pkgs. Below is the errors after calling "rosmake asctec_drivers --rosdep-install". Presently I have an impression that it might be an issue of having the right path to pkgs or stacks ? But I still cannot figure this out. NB: I posted this yesterday at the asctec-users forum before discovering this forum today.

[ rosmake ] Packages requested are: ['asctec_drivers']                           
[ rosmake ] Logging to directory/home/inf4/.ros/rosmake/rosmake_output-20110721-221425 
[ rosmake ] Expanded args ['asctec_drivers'] to: 
['asctec_msgs', 'pelican_urdf', 'asctec_proc', 'asctec_mon', 'asctec_autopilot'] 
[ rosmake ] Generating Install Script using rosdep then executing. This may take a minute, you will be prompted for permissions. . . 
rosdep executing this script: 
{{{ 
set -o errexit 
#No Packages to install 
}}} 
[ rosmake ] rosdep successfully installed all system dependencies               
[rosmake-0] Starting >>> rosbuild [ make ]                                       
[rosmake-0] Finished <<< rosbuild ROS_NOBUILD in package rosbuild 
 No Makefile in package rosbuild 
[ rosmake ] [ make ] [ rosbuild: 0.0 sec ]            [ 1 Active 1/50 Complete ] 
[rosmake-0] Starting >>> roslang [ make ]                                       
[rosmake-1] Starting >>> cpp_common [ make ]                                     
[rosmake-0] Finished <<< roslang ROS_NOBUILD in package roslang 
 No Makefile in package roslang 
[rosmake-1] Finished <<< cpp_common ROS_NOBUILD in package cpp_common           
[rosmake-0] Starting >>> roslib [ make ]                                         
[rosmake-1] Starting >>> roscpp_traits [ make ]                                 
[ rosmake ] [ make ] [ roslib: 0.0 sec ] [ roscpp_... [ 2 Active 4/50 Complete ] 
[rosmake-0] Finished <<< roslib ROS_NOBUILD in package roslib                   
[rosmake-1] Finished <<< roscpp_traits ROS_NOBUILD in package roscpp_traits     
[rosmake-1] Starting >>> rostime [ make ]                                       
[rosmake-1] Finished <<< rostime ROS_NOBUILD in package rostime                 
[rosmake-0] Starting >>> xmlrpcpp [ make ]                                       
[rosmake-1] Starting >>> roscpp_serialization [ make ]                           
[rosmake-1] Finished <<< roscpp_serialization ROS_NOBUILD in package roscpp_serialization 
[rosmake-0] Finished <<< xmlrpcpp ROS_NOBUILD in package xmlrpcpp               
[rosmake-1] Starting >>> rosconsole [ make ]                                     
[rosmake-1] Finished <<< rosconsole ROS_NOBUILD in package rosconsole           
[rosmake-0] Starting >>> std_msgs [ make ]                                       
[rosmake-0] Finished <<< std_msgs ROS_NOBUILD in package std_msgs               
[ rosmake ] [ make ] [ std_msgs: 0.0 sec ]           [ 1 Active 10/50 Complete ] 
[rosmake-1] Starting >>> pelican_urdf [ make ]                                   
[rosmake-0] Starting >>> rosgraph_msgs [ make ]                                 
[rosmake-0] Finished <<< rosgraph_msgs ROS_NOBUILD in package rosgraph_msgs     
[rosmake-0] Starting >>> roscpp [ make ]                                         
[rosmake-0] Finished <<< roscpp ROS_NOBUILD in package roscpp                   
[rosmake-0] Starting >>> asctec_msgs [ make ]                                   
[ rosmake ] [ make ] [ pelican_urdf: 0.1 sec ] [ ... [ 2 Active 13/50 Complete ] 
[ rosmake ] All 2 lines 
{------------------------------------------------------------------------------- 
  mkdir: kann Verzeichnis „build“ nicht anlegen: Keine Berechtigung 
-------------------------------------------------------------------------------} 
[ rosmake ] Output from build of package pelican_urdf written to: 
[ rosmake ]    /home/inf4/.ros/rosmake/rosmake_output-20110721-221425/pelican_urdf/build_output.log 
[rosmake-1] Finished <<< pelican_urdf [FAIL] [ 0.10 seconds ]                   
[ rosmake ] Halting due to failure in package pelican_urdf. 
[ rosmake ] Waiting for other threads to complete. 
[ rosmake ] All 2 lines 
{------------------------------------------------------------------------------- 
  mkdir: kann Verzeichnis „build“ nicht anlegen: Keine Berechtigung 
-------------------------------------------------------------------------------} 
[ rosmake ] Output from build of package asctec_msgs written to: 
[ rosmake ]    /home/inf4/.ros/rosmake/rosmake_output-20110721-221425/asctec_msgs/build_output.log 
[rosmake-0] Finished <<< asctec_msgs [FAIL] [ 0.10 seconds ]                     
[ rosmake ] Halting due to failure in package asctec_msgs. 
[ rosmake ] Waiting for other threads to complete. 
[ rosmake ] Results:                                                             
[ rosmake ] Built 15 packages with 2 failures.                                   
[ rosmake ] Summary output to directory                                         
[ rosmake ] /home/inf4/.ros/rosmake/rosmake_output-20110721-221425
edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
1

answered 2011-07-30 09:23:02 -0500

tfoote gravatar image

The problem you have is that the package you're trying to build has read only permissions on your filesystem. If you're using a binary installation you should need to build the package, it's already built. If you want to modify the package you should be downloading the packages you want to modify from source and adding them to the front of your ROS_PACKAGE_PATH.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-07-21 23:19:14 -0500

Seen: 297 times

Last updated: Sep 02 '11