Ask Your Question
0

rviz and image_view missing

asked 2011-07-06 12:13:22 -0500

kinoob gravatar image

Hi,

I installed using sudo apt-get install ros-diamondback-openni-kinect, and also ran rosmake openni_kinect --rosdep-install, which appeared to build correctly. Running roslaunch openni_camera openni_node.launch gives

started roslaunch server http://r-ubuntu-vbox:34230/

SUMMARY
========

PARAMETERS
 * /rosdistro
 * /openni_node1/use_indices
 * /openni_node1/depth_registration
 * /openni_node1/image_time_offset
 * /openni_node1/depth_frame_id
 * /openni_node1/depth_mode
 * /openni_node1/debayering
 * /rosversion
 * /openni_node1/projector_depth_baseline
 * /openni_node1/rgb_frame_id
 * /openni_node1/depth_rgb_translation
 * /openni_node1/depth_time_offset
 * /openni_node1/image_mode
 * /openni_node1/shift_offset
 * /openni_node1/device_id
 * /openni_node1/depth_rgb_rotation

NODES
  /
    openni_node1 (openni_camera/openni_node)
    kinect_base_link (tf/static_transform_publisher)
    kinect_base_link1 (tf/static_transform_publisher)
    kinect_base_link2 (tf/static_transform_publisher)
    kinect_base_link3 (tf/static_transform_publisher)

auto-starting new master
process[master]: started with pid [2560]
ROS_MASTER_URI=http://localhost:11311

setting /run_id to bdd14e7c-a82a-11e0-b20c-080027f524b1
process[rosout-1]: started with pid [2573]
started core service [/rosout]
process[openni_node1-2]: started with pid [2577]
process[kinect_base_link-3]: started with pid [2581]
process[kinect_base_link1-4]: started with pid [2584]
process[kinect_base_link2-5]: started with pid [2588]
process[kinect_base_link3-6]: started with pid [2590]
[ INFO] [1309996236.974618061]: [/openni_node1] Number devices connected: 1
[ INFO] [1309996236.975188996]: [/openni_node1] 1. device on bus 001:03 is a Xbox NUI Camera (2ae) from Microsoft (45e) with serial id 'A00361A06492045A'
[ INFO] [1309996236.977783740]: [/openni_node1] searching for device with index = 1
[ INFO] [1309996237.022679184]: [/openni_node1] Opened 'Xbox NUI Camera' on bus 1:3 with serial number 'A00361A06492045A'
[ INFO] [1309996237.044125778]: rgb_frame_id = '/openni_rgb_optical_frame' 
[ INFO] [1309996237.046913891]: depth_frame_id = '/openni_depth_optical_frame'

I'm running Ubuntu 10.10, Maverick Meerkat, on a VirtualBox virtual machine which in turn runs on Mac OSX.

Running rospack list-names gives

roslib
roslang
rosbuild
mk
rosemacs
rosmake
roscreate
rosunit
rosbash
rospack
rosclean
rosboost_cfg
rosdep
test_roslib
test_rosmake
test_rospack
test_rosdep
test_roscreate
image_geometry
opencv2
opencv_tests
cv_bridge
dynamic_reconfigure
driver_base
timestamp_tools
diagnostic_analysis
diagnostic_aggregator
self_test
diagnostic_updater
test_diagnostic_aggregator
visualization_msgs
nav_msgs
geometry_msgs
trajectory_msgs
actionlib_msgs
sensor_msgs
diagnostic_msgs
stereo_msgs
test_common_msgs
roscore_migration_rules
rospy
roslisp
roscpp_traits
roscpp_serialization
roscpp
xmlrpcpp
rostime
roswtf
message_filters
cpp_common
std_srvs
std_msgs
rosgraph_msgs
rosout
rosgraph
rosbag
rosrecord
rosservice
rosmsg
rosparam
rosmaster
roslaunch
rosbagmigration
rosconsole
topic_tools
rostest
rostopic
rosnode
test_rosparam
test_topic_tools
test_rostime
test_rospy
test_crosspackage
test_rostest
test_rosnode
test_roscpp
test_roscpp_serialization_perf
test_roscpp_serialization
test_rosservice
test_roslaunch
perf_roscpp
test_roswtf
test_rosbag
test_rosmaster
test_ros
test_rosgraph
test_roslib_comm
test_rosmsg
test_rostopic
xacro
tinyxml
filters
nodelet_topic_tools
test_nodelet
test_bond
nodelet
smclib
bfl
pluginlib
yaml_cpp
bond
actionlib
bondcpp
bondpy
camera_info_manager
image_transport
polled_camera
camera_calibration_parsers
bullet
tf_conversions
eigen
tf
angles
kdl
eigen_conversions
pcl
pcl_android
cminpack
pcl_ros
flann
nite
openni_camera_unstable
openni_tracker
openni
openni_camera

And this leads on to my problem: Neither rviz nor image_view is present, so I don't know how to easily get some image output to confirm that things are really working. ROS_PACKAGE_PATH is set to /opt/ros/diamondback/stacks. How do I get rviz or image_view to work?

Thanks!

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2011-07-06 16:02:50 -0500

Patrick Mihelich gravatar image

Install ros-diamondback-image-pipeline (stack containing image_view) and ros-diamondback-visualization (stack containing rviz) also.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-07-06 12:13:22 -0500

Seen: 767 times

Last updated: Jul 06 '11