Ask Your Question
0

turtlebot with gyro but no kinect

asked 2011-07-01 17:56:41 -0500

xalu gravatar image

updated 2011-07-01 18:14:07 -0500

I am trying to test out my set up. I just installed the gyro according to http://answers.ros.org/question/717/is-an-imu-required-to-run-turtlebot-stack. I want to verify its working correctly but when I run the calibration command

roslaunch turtlebot_calibration calibrate.launch

I am getting error " Still waiting for imu ".

Also, I am still waiting for my kinect, when I run

roslaunch turtlebot_bringup robot.launch

I get "[/openni_camera] No devices connected.... waiting for devices to be connected" also when I run the minimial.launch file I am getting this error as well...

respawning... IOError: [Errno 13] Permission denied: '/home/ros/.ros/log/a7cc963c-a446-11e0-a0ae-001d72a199a1/turtlebot_node-3.log' [turtlebot_node-3] process has died [pid 28495, exit code 1]. log files: /home/ros/.ros/log/a7cc963c-a446-11e0-a0ae-001d72a199a1/turtlebot_node-3*.log respawning...respawning...

*How can I test my gyro to make sure its working and get turtlebot working without kinect until I have it? Please include location of file to edit. *

Results of roswtf:

Beginning tests of your ROS graph. These may take awhile...
analyzing graph...
... done analyzing graph
running graph rules...
connection to [/app_manager] timed out
... done running graph rules
running tf checks, this will take a second...
... tf checks complete

Online checks summary:

Found 5 warning(s).
Warnings are things that may be just fine, but are sometimes at fault

WARNING The following node subscriptions are unconnected:
 * /diagnostic_aggregator:
   * /diagnostics
 * /robot_pose_ekf:
   * /imu/data
   * /odom
 * /robot_state_publisher:
   * /joint_states
 * /openni_manager:
   * /cloud_throttled

WARNING The following nodes are unexpectedly connected:
 * /openni_manager->/kinect_laser (/openni_manager/bond)
 * /kinect_breaker_enabler->/rosout (/rosout)
 * /pointcloud_throttle->/kinect_laser (/openni_manager/bond)
 * /app_manager->/rosout (/rosout)
 * /openni_camera->/kinect_laser_narrow (/openni_manager/bond)
 * /pointcloud_throttle->/rosout (/rosout)
 * /kinect_laser->/rosout (/rosout)
 * /robot_pose_ekf->/rosout (/rosout)
 * /kinect_laser_narrow->/rosout (/rosout)
 * /robot_state_publisher->/rosout (/rosout)
 * /diagnostic_aggregator->/rosout (/rosout)
 * /pointcloud_throttle->/kinect_laser_narrow (/openni_manager/bond)
 * /openni_camera->/kinect_laser (/openni_manager/bond)
 * /openni_camera->/rosout (/rosout)
 * /openni_manager->/rosout (/rosout)
 * /openni_manager->/kinect_laser_narrow (/openni_manager/bond)

WARNING These nodes have respawned at least once:
 * turtlebot_node-3 (9)
 * kinect_laser-12 (2)
 * kinect_laser_narrow-13 (2)

WARNING These nodes have died:
 * app_manager-2
 * turtlebot_laptop_battery-4

WARNING No tf messages

Found 2 error(s).

ERROR Could not contact the following nodes:
 * /app_manager

ERROR Errors connecting to the following services:
 * service [/turtlebot/start_app] appears to be malfunctioning: Unable to communicate with service [/turtlebot/start_app], address [rosrpc://ros-desktop:45707]
 * service [/turtlebot/list_apps] appears to be malfunctioning: Unable to communicate with service [/turtlebot/list_apps], address [rosrpc://ros-desktop:45707]
 * service [/turtlebot/stop_app] appears to be malfunctioning: Unable to communicate with service [/turtlebot/stop_app], address [rosrpc://ros-desktop:45707]

Thanks!

edit retag flag offensive close merge delete

Comments

eventhough the roslaunch is waiting for the kinect all the other software is still running and you can run robot.launch. It will just print to the screen leeting you know it's not there.
mmwise gravatar image mmwise  ( 2011-07-01 21:45:09 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2011-07-01 18:20:55 -0500

xalu gravatar image

updated 2011-07-03 18:08:53 -0500

mmwise gravatar image

okay. To answer my own question. I needed to edit permission..specifically of my Log folder. So I changed it to chmod -r 777 ~/.ros/log and I was able to get the minimal.launch file going.

After that I was able to get the calibration error to change from

waiting for IMU

to

[INFO] [WallTime: 1309587548.929387] Still waiting for scan

.. Which in my book right now means its working :D So I think my question is answered.

edit flag offensive delete link more
2

answered 2011-07-01 21:42:07 -0500

mmwise gravatar image

open up the turtlebot_dashboard click on the wrench icon to show the diagnostics. Then look at the gyro info under sensors, you will see whether the gyro status is OK. if you double click on the gyro item in the list you will see the the value of the calibration which is ~500

edit flag offensive delete link more

Comments

Thanks for tip. I am all green and my gyro is giving me updates so its working :)
xalu gravatar image xalu  ( 2011-07-02 15:39:31 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-07-01 17:56:41 -0500

Seen: 448 times

Last updated: Jul 03 '11