Ask Your Question
0

rxgraph No module named gobject (OS X)

asked 2011-06-26 15:48:49 -0500

jpitz31 gravatar image

updated 2011-06-27 03:52:08 -0500

kwc gravatar image

Hello, I am doing the tutorials on os x 10.6.7. When I run rxgraph, in the ROS topics tutorial section I get the following error "No module named gobject"

I have went back and ran rosdep install rsxtools and re-ran the roscpp_tutorials rospy_tutorials rxtools

Any ideas what is missing. Appears to be python related, just not sure what.

Cheers

Joe

edit retag flag offensive close merge delete

Comments

That's definitely a dependency installation issue. Also, both your question tags and your question mention "rsxtools", when the correct invocation is "rosdep install rxtools". Can you add the output of "rosdep satisfy rxtools" to your question (you can re-edit your question directly).
kwc gravatar image kwc  ( 2011-06-27 03:53:06 -0500 )edit
Thanks kwc, When I get home I will run rosdep satisfy rxtools and post the results. Joe
jpitz31 gravatar image jpitz31  ( 2011-06-27 04:31:30 -0500 )edit
kwc, I ran rosdep satisfy rxtools, rosdep returned #No packages to install, I then ran rosdep install rxtools, return was also: #No packages to install
jpitz31 gravatar image jpitz31  ( 2011-06-27 13:12:10 -0500 )edit
kwc, I went ahead and ran rosdep satisfy rxgraph and received the following: sudo port install py26-pil graphviz. I ran the install and re-ran the rosmake rxgraph. But when I attempted to run rxgraph I still received the error "No module named gobject" Joe
jpitz31 gravatar image jpitz31  ( 2011-06-27 17:11:08 -0500 )edit
Just realized that you're working with rxgraph. Can you try "rosdep install rxgraph" instead? I got thrown off by the original question description. Basically, you need to install wxpython via macports.
kwc gravatar image kwc  ( 2011-06-28 04:07:08 -0500 )edit
rosdep install rxgraph returns: #No packages to install. sudo port install py26-wxpython returns ---> Computing dependencies for py26-wxpython ---> Cleaning py26-wxpython. rxgraph still returns above error.
jpitz31 gravatar image jpitz31  ( 2011-06-28 15:19:53 -0500 )edit
what if you "port install py26-gobject"?
kwc gravatar image kwc  ( 2011-06-28 15:21:48 -0500 )edit
ran sudo port install py26-gobject, ---> Computing dependencies for py26-gobject ---> Cleaning py26-gobject, rxgraph still fails.
jpitz31 gravatar image jpitz31  ( 2011-06-29 13:23:07 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2011-09-02 12:06:00 -0500

kwc gravatar image

no activity > 1 month, closing

edit flag offensive delete link more
0

answered 2011-11-20 17:40:57 -0500

Joshua gravatar image

Seeing this issue on Mac OS X 10.7.1 with ROS Electric installed using the Homebrew instructions.

import gobject ImportError: No module named gobject

I don't see pygobject in homebrew, how are other Mac & Homebrew users satisfying this dependency?

edit flag offensive delete link more

Comments

I have the same problem with OSX 10.7.2, electric, and brew install.
Brian Gerkey gravatar image Brian Gerkey  ( 2011-11-28 07:53:15 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-06-26 15:48:49 -0500

Seen: 1,120 times

Last updated: Nov 20 '11