ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question
1

Object Recognition Kitchen (ORK) not installing correctly on Hydro

asked 2013-11-21 06:13:48 -0500

chase gravatar image

updated 2014-01-28 17:18:36 -0500

ngrennan gravatar image

I should start by saying that I am very new to linux and ROS. I am working out of Ubuntu 12.04 with ROS hydro. I would like to use Object Recognition Kitchen (ORK) in conjunction with a Kinect for hand grasp studies. I've confirmed that ORK will work with Hydro.

I followed the install instructions for groovy given at the ORK site.

I tried straight from the ROS repositories with ros-*-object-recognition-core but had no luck using rosinstall.Then I tried the rosinstall file and the build kept failing.

Finally I followed the directions to download and build from source for groovy, but replaced all groovy calls with hydro. I installed all the pipelines and ROS stuff and built with catkin_make. I did not receive any errors and it looks as though it built correctly.

Just to see if everything was working I followed the quick guide for ROS packages. I set up the environment as noted, launched roscore, and launched openni successfully.

But when trying to set up the capture workspace I get this:

zarathustra@zarathustra-MS-7693:~$ rosrun object_recognition_capture orb_template -o my_textured_plane
[rospack] Error: stack/package object_recognition_capture not found

zarathustra@zarathustra-MS-7693:~$ rosrun object_recognition_capture orb_track --track_directory my_textured_plane
[rospack] Error: stack/package object_recognition_capture not found

Thanks in advance for any help or suggestions.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2013-12-01 05:37:03 -0500

chase gravatar image

Found the problem for anyone else having similar issues: you have to make sure that ORK is installed in opt/ros/hydro/share so that it is on the correct ROS path. Otherwise you will need to source whatever path you install it under.

edit flag offensive delete link more

Question Tools

4 followers

Stats

Asked: 2013-11-21 06:13:48 -0500

Seen: 957 times

Last updated: Dec 01 '13