Running object_recognition (ORK) makes RViz with MoveIt Motion Planning Plugin unusable

asked 2015-01-12 04:25:47 -0500

dornhege gravatar image

updated 2015-01-12 04:26:50 -0500

I have created some weird problem, where I can't figure out what the reason is: RViz with the Motion Planning Plugin from moveit gets unusable when I run the ORK object detection in parallel. The GUI is very unresponsive, I takes more then 10 seconds to just turn the view, but it still works. Only RViz is affected, i.e. all other programs work fine. Also CPU and memory load are way under max, so that doesn't seem to be the issue.

The problem appears only in this combination, i.e. Motion Planning plugin in rviz and object detection running. When I stop object detection it takes about 20 seconds and rviz is responsive again, so it is definitely causing this somehow. Also the motion planning plugin only must be in the plugins list. It is not necessary to activate it. In contrast only loading the Planning Scene plugin works fine. It is also not necessary to run the move_group node in parallel.

I am running hydro on precise. Object Recognition is built from sources as the debs coredump according to the rosinstall file here: http://wg-perception.github.io/object... I am mainly running tabletop detection from a Gazebo Kinect on a simulated PR2, but a quick test with the LineMod config showed the same effect. I also tried building rviz from sources and there was no difference in the behavior.

Besides a solution I'd also be happy with any suggestions on what could be a possible cause to investigate.

edit retag flag offensive close merge delete

Comments

We observe the same problem here. Did you solve the problem?

BennyRe gravatar imageBennyRe ( 2015-06-03 05:38:13 -0500 )edit

The only workaround I use is to run the ork server and have a single on demand query, so that rviz is usable. This isn't really a solution, though.

dornhege gravatar imagedornhege ( 2015-06-05 07:22:59 -0500 )edit