ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

Problems running ppl_detection in astar-ros-pkg

asked 2011-06-21 06:58:22 -0500

Deepak gravatar image

updated 2011-06-21 08:26:06 -0500

kwc gravatar image


I am trying to use the ppl_detection in the astar-ros-pkg:

As soon as I run the node, it exits and throws me a segmentation fault.

the error displayed is given below:

[rviz-7] process has died [pid 4034, exit code -11].

edit retag flag offensive close merge delete

5 Answers

Sort by » oldest newest most voted

answered 2011-09-02 12:44:02 -0500

kwc gravatar image

No activity > 1 month, closing

edit flag offensive delete link more

answered 2011-11-08 17:30:30 -0500

Try changing line 468 of kinect_detect.cpp from: std::string model_string = "svm_models/" + model_name + ".model"; to: std::string model_string = "../svm_models/" + model_name + ".model";

This fixed the segfaulting for me.

edit flag offensive delete link more


worked for me changing that line to std::string model_string = "./svm_models/" + model_name + ".model"; as suggested by @IsaacSaito

Procópio gravatar image Procópio  ( 2012-01-17 23:44:10 -0500 )edit

answered 2011-12-01 11:29:07 -0500

130s gravatar image

updated 2011-12-05 09:13:35 -0500

If you believe the segmentation fault occurs at RViz, this thread might be of help.

Else if you experience seg-fault while trying to run kinect_detect, first of all the current implementation requires you run the command from the home directory of ppl_detection (by roscd ppl_detection or something. See around line#468 in kinect_detect.cpp where relative path of .model file is specified). Then try what @Liz Murphy suggests. If that still doesn't solve, modify the same part as:

std::string model_string = "./svm_models/" + model_name + ".model";

On one of my notebook (Ubuntu 11.04, Intel i7, ROS electric), I didn't have to do anything for kinect_detect, but on Turtlebot (eeepc), I had to do the above (maybe it's rooted in that the way fopen in C++ treats the current directory varies depending on the computer architecture? I haven't investigated further).


edit flag offensive delete link more


worked for me, changing the kinect_detect.cpp. thanks!
Procópio gravatar image Procópio  ( 2012-01-17 23:45:20 -0500 )edit

answered 2012-05-02 05:27:26 -0500

tayyab gravatar image

If rviz gives you an error you can always try removing the temporary folder created by rviz. considering you are in home directory

rm -rf .rviz

Now restart the rviz.

If kinect_detect gives you a segmentation fault even after the above changes, then just re build it once again by assuming you are in ppl_detection package path


now do

rosrun ppl_detection kinect_detect

hope it helps :)

edit flag offensive delete link more

answered 2011-06-21 21:00:46 -0500

The launch file contains a strange reference to a "trainer" package.

If that is the problem, check whether you can find the launchfile (i.e. have a look into the package) or try to edit the launchfile and remove args="--display-config $(find trainer)/kinect_detect.vcg", you might then need to add the necessary displays manually.

edit flag offensive delete link more


I have already edited the launch file and removed the trainer and replaced it with the 'ppl_detection'. Without this, the node was not running. After replacing, it launches the openni node, and rviz. Then when I try to run : rosrun ppl_detection kinect_detect That is when it quits.
Deepak gravatar image Deepak  ( 2011-06-21 21:58:29 -0500 )edit
even I am facing the same error. Have u been able to solve it ? Would be really thankful if u could help me.
siddhu723 gravatar image siddhu723  ( 2011-11-06 23:36:00 -0500 )edit

Question Tools


Asked: 2011-06-21 06:58:22 -0500

Seen: 773 times

Last updated: May 02 '12