Ask Your Question
0

dynamixel_motor with catkin

asked 2013-11-13 01:19:33 -0600

Dear everybody,

I am starting with ROS and my objective is to create a 3D laser scanner with a Hokuyo+Dynamixel servo. The Hokuyo nodes and laser_assembler are not a problem so far. However, I have no idea how to deal with the Dynamixel servo.

I tried to follow the dynamixel_motor tutorials starting with the second tutorial, which is supposed to be done first. The problem is that the instructions are given for the previous ROS build system. I tried the same with catkin:

$ catkin_create_pkg my_dynamixel_tutorial dynamixel_controllers

But later, roscd does not recognize the new package. I tried to run $ catkin_make and this is the error:

-- +++ processing catkin package: 'my_dynamixel_tutorial' -- ==> add_subdirectory(my_dynamixel_tutorial) CMake Error at /home/jabuntu/Dropbox/ros_ws/devel/share/dynamixel_controllers/cmake/dynamixel_controllersConfig.cmake:154 (find_package): Could not find module Findcontrol_msgs.cmake or a configuration file for package control_msgs.

Adjust CMAKE_MODULE_PATH to find Findcontrol_msgs.cmake or set control_msgs_DIR to the directory containing a CMake configuration file for control_msgs. The file will have one of the following names:

control_msgsConfig.cmake 
control_msgs-config.cmake

Call Stack (most recent call first): /opt/ros/hydro/share/catkin/cmake/catkinConfig.cmake:71 (find_package) my_dynamixel_tutorial/CMakeLists.txt:7 (find_package)

So it is not identified as a package. How can I fix this? Is there any other simplest way to use this servo together with ROS?

And finally, should I create another node in order to get motor state and publish tf in order to use laser_assembler?

Thank you very much!

edit retag flag offensive close merge delete

Comments

Do you have the package control_msgs installed?

BennyRe gravatar imageBennyRe ( 2013-11-13 03:35:16 -0600 )edit

Thank you for your advice. I ignored that since I installed ROS full, so I was assuming everything was installed. Now I'm able to continue :)

Javier V. Gómez gravatar imageJavier V. Gómez ( 2013-11-13 04:14:57 -0600 )edit

Cool. I'll post it as an answer, so you can mark the question as answered.

BennyRe gravatar imageBennyRe ( 2013-11-13 04:23:45 -0600 )edit

1 Answer

Sort by » oldest newest most voted
1

answered 2013-11-13 04:24:10 -0600

BennyRe gravatar image

Install the control_msgs package.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2013-11-13 01:19:33 -0600

Seen: 413 times

Last updated: Nov 13 '13