Ask Your Question
0

failed dependencies when install diamondback

asked 2011-08-09 20:41:45 -0500

sam gravatar image

updated 2011-08-25 02:10:57 -0500

I have tried sudo apt-get install ros-diamondback-pr2-desktop successfully

 sam@/opt/ros/diamondback/stacks/laser_drivers/hokuyo_node$ sudo apt-get      install ros-diamondback-pr2-desktop
 Reading package lists... Done
 Building dependency tree       
 Reading state information... Done
 ros-diamondback-pr2-desktop is already the newest version.
 The following packages were automatically installed and are no longer      required:
   libantlr-dev python-sip4-dev
 Use 'apt-get autoremove' to remove them.
 0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

 sam@/opt/ros/diamondback/stacks/laser_drivers/hokuyo_node$

When I run

 sudo apt-get install ros-diamondback-*

it shows

  ros-diamondback-graspit-simulator : Depends: libqt4-sql-psql but it is not      going to be installed
  ros-diamondback-warehousewg : Depends: xulrunner-dev but it is not going      to be installed
 E: Broken packages

My /etc/apt/sources.list:

 sam@/home/sam/code/ros/gazebo/debug$ cat /etc/apt/sources.list
 # deb cdrom:[Ubuntu 10.10 _Maverick Meerkat_ - Release amd64      (20101007)]/ maverick main restricted
 # See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade      to
 # newer versions of the distribution.

 deb http://archive.ubuntu.com/ubuntu maverick main restricted
 deb-src http://archive.ubuntu.com/ubuntu maverick main restricted

 ## Major bug fix updates produced after the final release of the
 ## distribution.

 ## N.B. software from this repository is ENTIRELY UNSUPPORTED by the      Ubuntu
 ## team. Also, please note that software in universe WILL NOT receive any
 ## review or updates from the Ubuntu security team.
 deb http://archive.ubuntu.com/ubuntu maverick universe
 deb-src http://archive.ubuntu.com/ubuntu maverick universe

 ## N.B. software from this repository is ENTIRELY UNSUPPORTED by the      Ubuntu 
 ## team, and may not be under a free licence. Please satisfy yourself as to 
 ## your rights to use the software. Also, please note that software in 
 ## multiverse WILL NOT receive any review or updates from the Ubuntu
 ## security team.
 deb http://archive.ubuntu.com/ubuntu maverick multiverse
 deb-src http://archive.ubuntu.com/ubuntu maverick multiverse

 ## Uncomment the following two lines to add software from the 'backports'
 ## repository.
 ## N.B. software from this repository may not have been tested as
 ## extensively as that contained in the main release, although it includes
 ## newer versions of some applications which may provide useful features.
 ## Also, please note that software in backports WILL NOT receive any review
 ## or updates from the Ubuntu security team.
 # deb http://tw.archive.ubuntu.com/ubuntu/ maverick-backports main      restricted universe multiverse
 # deb-src http://tw.archive.ubuntu.com/ubuntu/ maverick-backports main      restricted universe multiverse

 ## Uncomment the following two lines to add software from Canonical's
 ## 'partner' repository.
 ## This software is not part of Ubuntu, but is offered by Canonical and the
 ## respective vendors as a service to Ubuntu users.
 # deb http://archive.canonical.com/ubuntu maverick partner
 # deb-src http://archive.canonical.com/ubuntu maverick partner

 ## This software is not part of Ubuntu, but is offered by third-party
 ## developers who want to ship their latest software.
 deb http://extras.ubuntu.com/ubuntu maverick main
 deb-src http://extras.ubuntu.com/ubuntu maverick main

I run 'dpkg -s xulrunner-dev libqt4-sql-psql':

 sam@/home/sam/code/ros/gazebo/debug$ dpkg -s xulrunner-dev      libqt4-sql-psql
 Package `xulrunner-dev' is not installed and no info ...
(more)
edit retag flag offensive close merge delete

Comments

What OS are you running? can you post the full console output from your installation? tfoote ( 2011-08-11 18:47:49 -0500 )edit
I use ubuntu 10.10. I will revise it. Thank you~ sam ( 2011-08-13 00:20:27 -0500 )edit
possibly a different version of libqt4-sql-psql (and xulrunner-dev) already exist on your system. What does the output of "dpkg -s xulrunner-dev libqt4-sql-psql" say? hsu ( 2011-08-22 08:40:22 -0500 )edit
I have added the command result 'dpkg -s xulrunner-dev libqt4-sql-psql'. sam ( 2011-08-22 13:15:00 -0500 )edit
I have added the command result 'sudo apt-get install libqt4-sql-psql'. sam ( 2011-08-24 18:40:45 -0500 )edit
getting close, can you now post results of "sudo dpkg -l | grep qt4", thanks. hsu ( 2011-08-24 21:13:49 -0500 )edit
I have added the command result 'sudo dpkg -l | grep qt4'. sam ( 2011-08-25 02:11:41 -0500 )edit

5 answers

Sort by ยป oldest newest most voted
3

answered 2011-08-10 00:12:22 -0500

Bram van de Klundert gravatar image

he sam

when you run the command

sudo apt-get install ros-diamondback-*

you try to install every single package/stack available this way. this is way more than just normal diamondback. install instructions for diamondback can be found here: http://www.ros.org/wiki/ROS/Installation

about those dependencies, have you tried installing the dependencies with apt-get install, when i check it shows them as available (you might have to do an apt-get update)

edit flag offensive delete link more

Comments

I guess, the manual installation should lead to another error. When that happens, update the original post with those erros and the commands issued and always copy&paste the exact error messages instead of typing. dornhege ( 2011-08-10 02:22:03 -0500 )edit
I know typing is not the best way,but my output is chinese,I have tried to change it to english version,but not works. So I try to translate the original message to english version. I have successfully installed ROS by that command before,but now it would not work. I don't know why.Thank you~ sam ( 2011-08-12 04:39:36 -0500 )edit
In that case a translation is probably better ;) You can try export LANG=en_US and export LC_MESSAGES=en_US in the console you run the install from. In any way, can you give the information requested by tfoote and try the suggestion by Bram. dornhege ( 2011-08-12 05:13:38 -0500 )edit
I can run export LANG=en_US , but when I run export LC_MESSAGES=en_US, it shows that bash: warning: setlocale: LC_MESSAGES: cannot change locale (en_US): No such file or directory. What can I do next? Thank you~ sam ( 2011-08-13 00:19:11 -0500 )edit
For me LC_MESSAGE=en_US.UTF8 works. But this only gives english messages, which would be easier than translating. To solve the actual problem try the suggestion by Bram an post errors from that in english. dornhege ( 2011-08-13 01:47:48 -0500 )edit
Thank you~The message is changed to english version successfully. I have updated the original post to english version of output messages. sam ( 2011-08-21 21:38:14 -0500 )edit
0

answered 2011-09-20 02:45:34 -0500

sam gravatar image

I trace the problems found that I can't install libnss3-dev

 sam@/home/sam/code/ros/ai/cram/roslisp_repl$ sudo apt-get update
 Get:1 http://packages.ros.org maverick Release.gpg [198B]
 Ign http://packages.ros.org/ros/ubuntu/ maverick/main Translation-en                                   
 Hit http://ppa.launchpad.net maverick Release.gpg                                          
 Ign http://ppa.launchpad.net/abogani/ppa/ubuntu/ maverick/main      Translation-en
 Hit http://ppa.launchpad.net maverick Release.gpg                    
 Hit http://archive.ubuntu.com maverick Release.gpg                   
 Ign http://archive.ubuntu.com/ubuntu/ maverick/main Translation-en   
 Ign http://archive.ubuntu.com/ubuntu/ maverick/multiverse Translation-en
 Get:2 http://packages.ros.org maverick Release [3032B]               
 Ign http://ppa.launchpad.net/cnav/ppa/ubuntu/ maverick/main Translation-en                       
 Hit http://ppa.launchpad.net maverick Release.gpg                                          
 Ign http://ppa.launchpad.net/gummi/gummi/ubuntu/ maverick/main      Translation-en              
 Hit http://ppa.launchpad.net maverick Release                                              
 Ign http://packages.ros.org maverick/main amd64 Packages                                               
 Ign http://packages.ros.org maverick/main amd64 Packages                                   
 Hit http://ppa.launchpad.net maverick Release                        
 Hit http://ppa.launchpad.net maverick Release                                                          
 Get:3 http://extras.ubuntu.com maverick Release.gpg [72B]                                              
 Ign http://extras.ubuntu.com/ubuntu/ maverick/main Translation-en                                 
 Get:4 http://packages.ros.org maverick/main amd64 Packages [121kB]                         
 Hit http://ppa.launchpad.net maverick/main Sources                                              
 Hit http://extras.ubuntu.com maverick Release                                                   
 Hit http://extras.ubuntu.com maverick/main Sources                                               
 Ign http://archive.ubuntu.com/ubuntu/ maverick/restricted Translation-en     
 Ign http://archive.ubuntu.com/ubuntu/ maverick/universe Translation-en                             
 Hit http://extras.ubuntu.com maverick/main amd64 Packages                                          
 Hit http://archive.ubuntu.com maverick Release                                                     
 Hit http://ppa.launchpad.net maverick/main amd64 Packages                    
 Hit http://archive.ubuntu.com maverick/main Sources                          
 Hit http://ppa.launchpad.net maverick/main Sources                           
 Hit http://ppa.launchpad.net maverick/main amd64 Packages                    
 Hit http://archive.ubuntu.com maverick/restricted Sources                    
 Hit http://archive.ubuntu.com maverick/universe Sources                      
 Hit http://archive.ubuntu.com maverick/multiverse Sources                    
 Hit http://ppa.launchpad.net maverick/main Sources     
 Hit http://ppa.launchpad.net maverick/main amd64 Packages                    
 Hit http://archive.ubuntu.com maverick/main amd64 Packages                   
 Hit http://archive.ubuntu.com maverick/restricted amd64 Packages
 Hit http://archive.ubuntu.com maverick/universe amd64 Packages
 Hit http://archive.ubuntu.com maverick/multiverse amd64 Packages
 Fetched 125kB in 7s (15.7kB/s)                                                                         
 Reading package lists... Done

 sam@/home/sam/code/ros/ai/cram/roslisp_repl$ sudo apt-get install      libnss3-dev
 Reading package lists... Done
 Building dependency tree       
 Reading state information... Done
 Some packages could not be installed. This may mean that you have
 requested an impossible situation or if you are using the unstable
 distribution that some required packages have not yet been created
 or been moved out of Incoming.
 The following information may help to resolve the situation:

 The following packages have unmet dependencies:
  libnss3-dev : Depends: libnss3-1d (< 3.12.7-0ubuntu1.1~) but      3.12.9+ckbi-1.82-0ubuntu0.10.10.1 is to be installed
 E: Broken packages

 sam@/home/sam/code/ros/ai/cram/roslisp_repl$

I found that when I add some sources on /etc ... (more)

edit flag offensive delete link more
0

answered 2011-08-24 23:11:23 -0500

dornhege gravatar image

updated 2011-08-25 07:34:26 -0500

Based on this output I suspect that something got mixed up with your packages.

The following packages have unmet dependencies:
libqt4-sql-psql : Depends: libqt4-sql (= 4:4.7.0-0ubuntu4) but      4:4.7.0-0ubuntu4.3 is to be installed
Depends: libqtcore4 (= 4:4.7.0-0ubuntu4) but      4:4.7.0-0ubuntu4.3 is to be installed
E: Broken packages

I would suggest to just remove the packages in question (probably all qt4 packages is best), run apt-get update and then reinstall the packages. This should get you synched back with your ubuntu repositories. That also goes for the xulrunner* packages and possibly more dependencies from that.

Did you enable updates and security repositories as tfoote suggested? For me that makes the version difference from ...0ubuntu4 to ...0ubuntu4.3

Got my hands on a maverick system:

apt-cache policy libqt4-sql-psql 
libqt4-sql-psql:
Installed: 4:4.7.0-0ubuntu4.3
Candidate: 4:4.7.0-0ubuntu4.3
Version table:
*** 4:4.7.0-0ubuntu4.3 0
    500 http://de.archive.ubuntu.com/ubuntu/ maverick-updates/main i386 Packages
    500 http://security.ubuntu.com/ubuntu/ maverick-security/main i386 Packages
    100 /var/lib/dpkg/status
 4:4.7.0-0ubuntu4 0
    500 http://de.archive.ubuntu.com/ubuntu/ maverick/main i386 Packages

According to you output of dpkg -l which shows the ubuntu4.3 versions to be installed I think when you installed the other qt4 packages you had security enabled and now you disabled it leaving incompatible packages.

edit flag offensive delete link more

Comments

What package I should remove? Is that package will related with programs which I'm using now? sam ( 2011-08-25 02:13:42 -0500 )edit
All that seem to make a problem and their dependencies. Other things might not work, so the idea is to immediately reinstall those packages from your current apt-sources (using to matching versions). As qt4 seems to be involved I would remove/reinstall all qt4 packages (dpkg -l |grep qt4 for a list) dornhege ( 2011-08-25 03:37:50 -0500 )edit
What's difference between 'do nothing' and 'remove and reinstall qt4 packages',if I don't install any new packages? Or what should I remove and what new package should I install? sam ( 2011-08-25 04:30:42 -0500 )edit
It will remove the package with name X that you have installed and reinstall package X from the ubuntu sources. Usually nothing should change, but I suspect that some packages that you have installed are different than they should be, reinstalling should fix that. dornhege ( 2011-08-25 05:41:41 -0500 )edit
Is there any way not to remove the basic libs and reinstall? Because of dependencies,it will let me reinstall too many program I already in used. sam ( 2011-08-25 14:11:30 -0500 )edit
Your dpkg -l shows that many packages are actually ahead in version. So enableing security + apt-get update might already work without the need to reinstall. You can als try apt-get --reinstall install <package> directly. dornhege ( 2011-08-25 19:52:59 -0500 )edit
I am confused how to enable security and '--reinstall install' means 'sudo apt-get --reinstall install qt4-*' ? sam ( 2011-08-25 20:29:03 -0500 )edit
0

answered 2011-08-13 07:15:19 -0500

tfoote gravatar image

Two suggestions. It appears that xulrunner-dev is in the security repository. Can you check that you have the security repo in your sources. http://packages.ubuntu.com/maverick/xulrunner-dev

Also, could you try installing ros-diamondback-pr2-desktop alone. It's possible that you have a stale package in your repo which has been removed in your local cache which is not version compatible.

Also most of those messages translate by google to say that they're already at the newest version. I suspect that most of what you want is already there.

Lastly make sure to apt-get update before trying to install or upgrade.

edit flag offensive delete link more

Comments

I updated the original post with ros-diamondback-pr2-desktop. And I have tried apt-get update but still the same condition. How to check I have the security repo in your sources or not? Thank you~ sam ( 2011-08-21 21:55:13 -0500 )edit
Post the contents of /etc/apt/sources.list dornhege ( 2011-08-21 22:09:07 -0500 )edit
I have posted the content of /etc/apt/sources.list. sam ( 2011-08-24 18:41:23 -0500 )edit
0

answered 2011-09-27 07:32:20 -0500

akargol gravatar image

I had a similar problem on a system where I had fiddled with the list of available repositories. The problem was that apt-get knew that packages were available (libqt4-dev was one of them), but couldn't actually connect to the proper location to download them. The error messages you're getting look pretty similar to what I had. If I remember correctly, resetting /etc/apt/sources.list to a default solved most of my problems, so it may be worth a shot.

edit flag offensive delete link more

Comments

What you mean 'default'? When I first encounter this problem,sources.list is also an default configuration. sam ( 2011-09-27 18:30:24 -0500 )edit
By 'default' I mean the settings for a clean ubuntu install. At some point I had changed which lines in sources.list were commented and which weren't, and I also changed some of the update manager settings. Resetting both to factory settings (essentially), solved my problem. akargol ( 2011-09-29 15:47:12 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Stats

Asked: 2011-08-09 20:41:45 -0500

Seen: 1,022 times

Last updated: Sep 27 '11