Ask Your Question
0

rosdep update for Fedora

asked 2013-11-08 12:02:41 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

I am configuring a user account on a Fedora machine to use ROS which is installed in the administer account. When I use

$rosdep update

reading in sources list data from /etc/ros/rosdep/sources.list.d ... (couple of lines that I am not allowed to put here, they are online link) Ignore legacy gbpdistro "groovy" Ignore legacy gbpdistro "hydro" Query rosdistro index ... Add distro "groovy" Add distro "hydro" updated cache in /home/solmaz/.ros/rosdep/sources.cache

Then when I try

$ source /opt/ros/grooby/setup.bash

I get

CATKIN_SHELL=bash: Command not found. Illegal variable name.

or when I try

$ export | grep ROS

I get

export: Command not found.

I need help in fixing this. Please explain your solution a bit in detail.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2013-11-18 19:14:00 -0500

tfoote gravatar image

It looks like you are not using bash? Maybe you're using sh or tcsh or zsh?

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2013-11-08 12:02:41 -0500

Seen: 214 times

Last updated: Nov 18 '13