Ask Your Question
0

Problems with Logger levels

asked 2013-11-06 10:57:21 -0500

MarcosPB gravatar image

Hello everyone, I have one node and I would like to put ROS_INFO_STREAM but it doesn't appear in my screen, it works when I put ROS_FATAL_STREAM, I know that I can change in rqt_loggerlevel but I must put it working in the code because I don't have enough time to change it after it start. Sorry for the bad English.

Thanks!

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
2

answered 2018-07-18 15:48:59 -0500

Mark Rose gravatar image

By default all logging goes to the ROS log files. You have to specify output:=screen as a parameter to the node in order to divert the logging to the console. Or, in a launch file:

 <node name="..." pkg="..." type="..." output="screen">
     ...
 </node>`
edit flag offensive delete link more

Comments

This is probably the correct answer. But it is worth also pointing out that you can also change the log levels programmatically

jarvisschultz gravatar imagejarvisschultz ( 2018-07-18 16:00:01 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2013-11-06 10:57:21 -0500

Seen: 124 times

Last updated: Jul 18 '18