Ask Your Question
1

Suspected bug in USARSim/ROS

asked 2013-10-31 05:03:04 -0500

RB gravatar image

updated 2013-11-04 00:16:45 -0500

Hi, After several attempts I have been able to generate a bag file containing logged

transform and laser scan data. when I type

root@ubuntu:~/fuerte_workspace/sandbox# rosbag info mylaserdata.bag

path: mylaserdata.bag

version: 2.0

duration: 7:28s (448s)

start: Oct 31 2013 21:20:39.34 (1383234639.34)

end: Oct 31 2013 21:28:07.46 (1383235087.46)

size: 3.7 MB

messages: 24650

compression: none [5/5 chunks]

types: tf/tfMessage [94810edda583a504dfda3829e70d7eec]

topics: /tf 24650 msgs : tf/tfMessage (2 connections)

But a standard bag from willow garage contains

types: sensor_msgs/LaserScan [90c7ef2dc6895d81024acba2ac42f369] tf/tfMessage [94810edda583a504dfda3829e70d7eec]

topics: /base_scan 924 msgs : sensor_msgs/LaserScan

          /tf          2769 msgs    : tf/tfMessage

I started gmapping by

rosrun gmapping slam_gmapping scan:=lms200 _odom_frame:=odom

so there is no information regarding /lms200.

rxgraph output gives no information of the error image description

but rviz information does not match with auto generated transform tree. There is no messeges in /lms200 and we have to manually add /lms200 through rviz window image description

Again rostopic echo /lms200 to see if there are any published messages Then nothing appears.

PLZ help.

* I know this USARSim/Ros is used in robo cup as well but no one mentioned about the error.*

edit retag flag offensive close merge delete

Comments

How did you record that bag file? Was "/lms200" topic available during recording?

ZdenekM gravatar imageZdenekM ( 2013-10-31 05:56:25 -0500 )edit

ZdenekM, rosbag record -O mylaserdata.bag /lms200 /tf. But no sensor message in the information. So ultimately /lms200 can't capture the messege.

RB gravatar imageRB ( 2013-10-31 07:14:26 -0500 )edit

Did you check if the laser topic was available during recording? Can you try to run your simulation and then "rostopic list" to see what topics are available?

ZdenekM gravatar imageZdenekM ( 2013-10-31 07:43:17 -0500 )edit

I haven't check that one, but rxgraph out put gives /lms200. I will check and tell. Have you figured out the problem.

RB gravatar imageRB ( 2013-10-31 08:05:56 -0500 )edit

You can also try "rostopic echo /lms200" to see if there are any published messages...

ZdenekM gravatar imageZdenekM ( 2013-10-31 08:07:45 -0500 )edit

Have you received LaserScan messeges correctly using USARSim/ROS

RB gravatar imageRB ( 2013-10-31 10:07:42 -0500 )edit

I'm not using USARSim.

ZdenekM gravatar imageZdenekM ( 2013-10-31 10:08:56 -0500 )edit

The bug is that the tf tree instantiated by USARSimRos does not contain the /lms200 node, although expected.

kr1zz gravatar imagekr1zz ( 2013-11-03 21:40:12 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2013-11-21 05:30:44 -0500

RB gravatar image
  1. Use UDK-2013-07 and USARSim-current ($ git clone git://git.code.sf.net/p/usarsim/code usarsim-code (Under proxy, please try "$ git clone http://git.code.sf.net/p/usarsim/code usarsim-code"))
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2013-10-31 05:03:04 -0500

Seen: 178 times

Last updated: Nov 21 '13