ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | Q&A
Ask Your Question

No display on rviz screen

asked 2013-10-31 01:26:00 -0500

Akshay_Bhardwaj_nsit gravatar image

updated 2013-11-14 10:13:45 -0500

tfoote gravatar image

i followed urdf tutorials under ros documentation and ran this:

roslaunch urdf_tutorial display.launch model:=06-flexible.urdf gui:=True

As a result rviz opens and it's visualizer is pitch black. I also checked RobotModel option in add in lower left corner. I then tried changing fixed and reference frame to base link. But robot is still nowhere to be seen. There is still this big black thing in 3D model. Please help. I have ROS groovy on Ubuntu 12.04.

edit retag flag offensive close merge delete



Are you running under a VM?

rnunziata gravatar image rnunziata  ( 2013-10-31 02:02:02 -0500 )edit

try rosrun rviz rviz. Try different color combination for TF, LaserScan etc

RB gravatar image RB  ( 2013-10-31 02:33:32 -0500 )edit

@rnunziata: I'm using a VM and having this problem. Any recommendations?

eric-wieser gravatar image eric-wieser  ( 2016-04-20 12:20:43 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted

answered 2013-11-07 01:01:55 -0500

Akshay_Bhardwaj_nsit gravatar image

I followed the tutorial 'overlaying with catkin workspace' and the problem is solved, though i still don't understand what was the problem. Any possible explanations?

edit flag offensive delete link more

answered 2013-10-31 15:54:01 -0500

doudoushuixiu gravatar image

i'm not sure . maybe u should add the robot into the rviz,

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower


Asked: 2013-10-31 01:26:00 -0500

Seen: 1,235 times

Last updated: Nov 07 '13