Ask Your Question
2

image_transport compressed plugin error

asked 2011-03-03 08:59:21 -0500

Akin gravatar image

Hi,

When I run image_transport to decompress color images coming from openni I receive this error:

rosrun image_transport republish compressed in:=/camera/rgb/image_color/compressed 
terminate called after throwing an instance of 'image_transport::TransportLoadException' what():  Unable to load plugin for transport 'compressed', error string: According to the loaded plugin descriptions the class image_transport/compressed_sub with base class type image_transport::SubscriberPlugin does not exist. Declared types are  compressed_sub image_transport/raw_sub theora_sub

I see that the compressed plugin is installed:

rosrun image_transport list_transports 
Declared transports:
compressed
image_transport/raw
theora (*): Not available. Try 'rosmake theora_image_transport'.

Details:
----------
"compressed"
 - Provided by package: compressed_image_transport
 - Publisher: This plugin publishes a CompressedImage using either JPEG or PNG compression.
 - Subscriber: This plugin decompressed a CompressedImage topic.

Does any one know why the decompression does not work?

I am using Diamondback...

Thanks

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2011-03-03 09:04:22 -0500

Akin gravatar image

It was a problem of ROS_PACKAGE_PATH which was bizarrely set to point at another image_transport folder. Setting it to Diamondback solved the problem.

edit flag offensive delete link more

Comments

I am definitely coming across with the same problem. Can you tell me more details about how to change the "ROS_PACKAGE_PATH" please? Thanks!

grapeson gravatar image grapeson  ( 2017-10-31 12:15:10 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-03-03 08:59:21 -0500

Seen: 3,176 times

Last updated: Mar 03 '11