Ask Your Question
1

segmentation fault on running stageros

asked 2011-02-26 17:09:51 -0500

Aravindhan K Krishnan gravatar image

updated 2011-02-28 17:10:34 -0500

Eric Perko gravatar image

I am trying to run exploration demo in explore_stage as described in ( http://www.ros.org/wiki/explore_stage ). When I run "roslaunch explore_stage explore.launch" I get the following error.

[stage-1] process has died [pid 11456, exit code -11]. log files: /home/aravindhan/.ros/log/bd966512-423d-11e0-b00f-5c260a051546/stage-1*.log

From the launch file, I can see that the nodes stageros and static_transform_publisher are launched. So, I tried to launch stageros manually on command line with maze.world file as parameter. It gives a segmentation fault. Any help?


I am using diamondback.

stageros crashes even with the new format of world files.

I changed explore.launch file to launch "stage" instead of "stageros" and the roslaunch seemed to launch stage.

(Is it ok to change stageros to stage? What is the difference between the two.?)

But, after stage is launched I get this error

[Loading __name:=stage]err: unable to open world file __name:=stage : No such file or directory (/backup/Softwares/Stage-3.2.2-Source/libstage/worldfile.cc Load)

worldfile.cc is found in that path and the file permissions are right.

Has anybody run this demo before.? Finding a tough time to get his working.!


I am copying the stack trace of the crash below.

It crashes at line number 196 in stageros.cpp. Looking at the comments at line nos 193-194, is it a known issue? Any fixes for this?

193 // Apparently an Update is needed before the Load to avoid crashes on 194 // startup on some systems.

195 this->UpdateWorld();

196 this->world->Load(fname);

==28396== Process terminating with default action of signal 11 (SIGSEGV): dumping core ==28396== Access not within mapped region at address 0x430

==28396== at 0x4E0C926: ??? (in /usr/lib/mesa/libGL.so.1.2)

==28396== by 0x467DC06: Stg::Canvas::resize(int, int, int, int) (canvas.cc:1288)

==28396== by 0x47082DA: Fl_Group::resize(int, int, int, int) (in /usr/lib/libfltk.so.1.1)

==28396== by 0x474470B: Fl_Window::resize(int, int, int, int) (in /usr/lib/libfltk.so.1.1)

==28396== by 0x4742B10: fl_handle(_XEvent const&) (in /usr/lib/libfltk.so.1.1)

==28396== by 0x47436AD: ??? (in /usr/lib/libfltk.so.1.1)

==28396== by 0x474394C: fl_wait(double) (in /usr/lib/libfltk.so.1.1)

==28396== by 0x46F1B94: Fl::wait(double) (in /usr/lib/libfltk.so.1.1)

==28396== by 0x46F1C3B: Fl::check() (in /usr/lib/libfltk.so.1.1)

==28396== by 0x468B36B: Stg::WorldGui::Load(char const*) (worldgui.cc:262)

==28396== by 0x8055AEE: StageNode::StageNode(int, char*, bool, char const) (stageros.cpp:196)

==28396== by 0x805A4BE: main (stageros.cpp:427)

edit retag flag offensive close merge delete

Comments

Could you post the output you get when you run stageros on the command line? Or any helpful output from the log file specified? Are there any error messages before Stage segfaults?
Eric Perko gravatar image Eric Perko  ( 2011-02-27 04:40:12 -0500 )edit

3 Answers

Sort by ยป oldest newest most voted
3

answered 2011-02-27 04:39:22 -0500

Eric Perko gravatar image

updated 2011-02-28 17:27:22 -0500

I took a quick look at the launch files involved. I'm assuming you are using Cturtle or Diamondback. If so, the Stage world file maze.world looks like it hasn't been upgraded to the new world file format. For info on how to do that, see stage_navigation. A bad world file will cause Stage to crash, so this may be the source of your problems.

stageros is the ROS wrapper around Stage that actually exposes data from Stage on ROS topics. If you want ROS integration with Stage, you will have to run stageros.

Update: I checked out the bosch packages required to run this tutorial. You actually have to upgrade 3 of the files in the bosch_worlds directory before the explore.launch file will run properly. I've made a patch to bosch_worlds available in my Dropbox. Applying those changes to the 3 files in bosch_worlds allowed the explore.launch file to run without modification (after rosmake explore_stage of course)

edit flag offensive delete link more

Comments

I'm new to linux. Could you tell me how to patch your file in old bosch_worlds file? Thank you!
ParNurZeal gravatar image ParNurZeal  ( 2012-01-02 14:32:33 -0500 )edit
Are you actually having trouble with it? It looks like bosch_worlds was updated to include that patch. A quick check would be to look at the segway.inc file - if the origin is called origin and has 4 elements instead of 3, then it should be campatible with Diamondback's Stage.
Eric Perko gravatar image Eric Perko  ( 2012-01-03 19:25:01 -0500 )edit
0

answered 2011-02-28 23:21:32 -0500

Aravindhan K Krishnan gravatar image

updated 2011-02-28 23:25:19 -0500

Solved.! Problem was with the graphics libraries.. The stack trace says mesa/libGL.so. Installed nvidia drivers and stageros works now. Demo runs after making the "Update" posted above. Thanks.

edit flag offensive delete link more

Comments

Ahhh... ya... you generally need a good set of 3d drivers for Stage, and absolutely must have for rviz and Gazebo.
Eric Perko gravatar image Eric Perko  ( 2011-03-01 03:48:56 -0500 )edit
To make it easier to find in the future, make sure to "accept" whichever answer you believe is the best solution for your question. This will make it easier for others with the same problem to find the answer in the future.
Eric Perko gravatar image Eric Perko  ( 2011-03-01 03:52:02 -0500 )edit
0

answered 2012-10-19 03:43:43 -0500

Rahndall gravatar image

I have tried the patch using fuerte as distribution, but it doesn't work.. I got this errors:

Hunk #1 FAILED at 1.
1 out of 1 hunk FAILED -- saving rejects to file sick.inc.rej
patching file maze.world
Hunk #1 FAILED at 10.
Hunk #2 FAILED at 19.
Hunk #3 FAILED at 33.
3 out of 3 hunks FAILED -- saving rejects to file maze.world.rej
patching file segway.inc
Hunk #1 FAILED at 3.
Hunk #2 FAILED at 21.
2 out of 2 hunks FAILED -- saving rejects to file segway.inc.rej

Any suggestions? Thanks

edit flag offensive delete link more

Comments

Have you checked to see if the underlying file includes the changes in that patch? From an earlier comment, bosch_worlds was apparently updated at some point for the newer version of Stage. Try running without applying the patch and see if you get the same error as the OP.

Eric Perko gravatar image Eric Perko  ( 2012-10-19 21:28:32 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-02-26 17:09:51 -0500

Seen: 1,257 times

Last updated: Oct 19 '12