ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question
0

How to fix catkin_make error for px-ros-pkg?

asked 2013-10-11 06:04:38 -0600

AmanJotwani gravatar image

updated 2013-11-18 16:52:37 -0600

tfoote gravatar image

Hello,

I am trying to use the ROS interface for the PX4flow optical flow board. I git cloned px-ros-pkg into my catkin workspace src subdirectory. This is what i get when i catkin_make:-

 Base path: /home/aman/new_catkin_ws
Source space: /home/aman/new_catkin_ws/src
Build space: /home/aman/new_catkin_ws/build
Devel space: /home/aman/new_catkin_ws/devel
Install space: /home/aman/new_catkin_ws/install
####
#### Running command: "make cmake_check_build_system" in "/home/aman/new_catkin_ws/build"
####
-- Using CATKIN_DEVEL_PREFIX: /home/aman/new_catkin_ws/devel
-- Using CMAKE_PREFIX_PATH: /opt/ros/hydro
-- This workspace overlays: /opt/ros/hydro
-- Using Debian Python package layout
-- Using CATKIN_ENABLE_TESTING: ON
-- Call enable_testing()
-- Using CATKIN_TEST_RESULTS_DIR: /home/aman/new_catkin_ws/build/test_results
-- Found gtest sources under '/usr/src/gtest': gtests will be built
-- catkin 0.5.74
-- BUILD_SHARED_LIBS is on
-- ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
-- ~~  traversing 3 packages in topological order:
-- ~~  - px_comm
-- ~~  - mavlink_serial_client
-- ~~  - px4flow
-- ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
-- +++ processing catkin package: 'px_comm'
-- ==> add_subdirectory(px-ros-pkg/px_comm)
-- px_comm: 3 messages, 1 services
-- +++ processing catkin package: 'mavlink_serial_client'
-- ==> add_subdirectory(px-ros-pkg/drivers/mavlink_serial_client)
CMake Error at /home/aman/new_catkin_ws/devel/share/px_comm/cmake/px_commConfig.cmake:130 (message):
  Project 'mavlink_serial_client' tried to find library 'px_comm_dds'.  The
  library is neither a target nor built/installed properly.  Did you compile
  project 'px_comm'? Did you find_package() it before the subdirectory
  containing its code is included?
Call Stack (most recent call first):
  /opt/ros/hydro/share/catkin/cmake/catkinConfig.cmake:72 (find_package)
  px-ros-pkg/drivers/mavlink_serial_client/CMakeLists.txt:4 (find_package)


-- Configuring incomplete, errors occurred!
make: *** [cmake_check_build_system] Error 1
Invoking "make cmake_check_build_system" failed

Why is this happening and what is the fix? Thanks.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2013-10-12 04:32:21 -0600

kalectro gravatar image

It looks like px_comm exports the library in its catkin_package() command but it does not pass the if statement if(DEFINED ENV{NDDSHOME}) in its CMakeLists.txt, so it does not build the library

edit flag offensive delete link more

Comments

I just checked that and turns out it does pass the above statement. Here's the line - if(DEFINED ENV{NDDSHOME}) set(NDDSHOME $ENV{NDDSHOME}) Thanks though.

AmanJotwani gravatar image AmanJotwani  ( 2013-10-12 07:41:23 -0600 )edit

Instead of catkin, i did rosbuild, and it worked out fine. But i am still interested to know where i was going wrong with the catkin_make. :-)

AmanJotwani gravatar image AmanJotwani  ( 2013-11-06 02:37:01 -0600 )edit

Question Tools

1 follower

Stats

Asked: 2013-10-11 06:04:38 -0600

Seen: 1,286 times

Last updated: Oct 12 '13