Ask Your Question
11

ROS groovy update screwed up workspace setup in some cases?

asked 2013-10-02 07:40:21 -0500

updated 2013-10-03 22:50:44 -0500

After updating ROS groovy from .debs today, the following happens with our software setup:

Source groovy setup:

source /opt/ros/groovy/setup.bash

Output of "env | grep ROS":

ROS_ROOT=/opt/ros/groovy/share/ros
ROS_PACKAGE_PATH=/opt/ros/groovy/share:/opt/ros/groovy/stacks
ROS_MASTER_URI=http://localhost:11311
ROS_TEST_RESULTS_DIR=/home/kohlbrecher/flor_repo/catkin_ws/build/test_results
ROSLISP_PACKAGE_DIRECTORIES=
ROS_DISTRO=groovy
ROS_ETC_DIR=/opt/ros/groovy/etc/ros

sourcing a previously working setup.bash of a rosbuild workspace:

source setup.bash

results in the following output:

kohlbrecher@sk-i7:~/flor_repo/rosbuild_ws$ source setup.bash
bash: /share/rosbash/rosbash: No such file or directory
[rospack] Warning: ROS_ROOT=/share/ros is not a directory

Output of "env | grep ROS":

ROS_ROOT=/share/ros
ROS_PACKAGE_PATH=[OMITTED FOR BREVITY]
ROS_MASTER_URI=http://localhost:11311
ROS_WORKSPACE=/home/kohlbrecher/flor_repo/rosbuild_ws
ROS_TEST_RESULTS_DIR=/home/kohlbrecher/flor_repo/catkin_ws/build/test_results
ROSLISP_PACKAGE_DIRECTORIES=/home/kohlbrecher/flor_repo/catkin_ws/devel/share/common-lisp
ROS_DISTRO=groovy
ROS_ETC_DIR=/etc/ros

Any ideas what´s going on here? The rosbuild workspace is depending on a catkin workspace. I´ll try reinstalling our setup from scratch next, to see if that solves the problem.

/edit: Tried installing from scratch using our install scripts and these also do not work anymore.

/edit: Related Q/A here

edit retag flag offensive close merge delete

Comments

Does it help to `rosws regenerate` the setup.bash?

dornhege gravatar imagedornhege ( 2013-10-02 07:57:27 -0500 )edit

rosws regenerate did not help in my case; I'm seeing the same issue

dcconner gravatar imagedcconner ( 2013-10-02 08:52:59 -0500 )edit

I'm seeing this problem too. Since ROS_ROOT has changed from the correct value of `/opt/ros/groovy/share/ros` to `/share/ros`, all tab-completion fails because they rely on rosbash (which needs ROS_ROOT set properly). As a *very* temporary fix, you can `export ROS_ROOT=/opt/ros/groovy/share/ros` and it appears to fix the problem. On systems sourcing a Catkin workspace, this problem can be fixed by running catkin_make in the workspace. This will set ROS_ROOT correctly.

Calder gravatar imageCalder ( 2013-10-02 11:26:25 -0500 )edit

I did it! I'm just waiting for an oficial solution! export ROS_ROOT=/opt/ros/groovy/share/ros export ROS_ETC_DIR=/opt/ros/groovy/etc/ros Thank you!

barcelosandre gravatar imagebarcelosandre ( 2013-10-02 17:03:42 -0500 )edit
3

I had to delete the workspace devel folder and then run catkin_make to fix the problem for me.

mboulet gravatar imagemboulet ( 2013-10-03 06:11:53 -0500 )edit

2 Answers

Sort by » oldest newest most voted
11

answered 2013-10-03 07:20:07 -0500

barcelosandre gravatar image

The solution is delete your "devel" and "build" directories, then make a "catkin_make". It will solve the problem.

edit flag offensive delete link more

Comments

yup, regenerating "devel" and "build" on my workspace did the trick. Thanks!

Martin Peris gravatar imageMartin Peris ( 2013-10-03 18:49:45 -0500 )edit

Solved my problem, thanks!

mortenpj gravatar imagemortenpj ( 2013-10-13 22:15:45 -0500 )edit
0

answered 2013-10-11 05:29:20 -0500

fivef gravatar image

For rosbuild workspaces rosws regenerate works.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

3 followers

Stats

Asked: 2013-10-02 07:40:21 -0500

Seen: 988 times

Last updated: Oct 11 '13