ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

[turtlemimic.launch] is neither a launch file in package [test_launch] nor is [test_launch] a launch file name?

asked 2013-10-02 06:20:39 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

I have done as the tutorials of ROS in the part of 'UsingRqtconsoleRoslaunch' but the still gets the error '[turtlemimic.launch] is neither a launch file in package [test_launch] nor is [test_launch] a launch file name'

edit retag flag offensive close merge delete

4 Answers

Sort by ยป oldest newest most voted

answered 2013-11-18 22:15:59 -0500

Zargol gravatar image

I think you should "overlay your workspace on top of your environment", so cd catkin_ws source devel/setup.bash

then launch your file!

edit flag offensive delete link more


i did this but sill have the same problem

bahaa gravatar image bahaa  ( 2014-01-01 09:00:42 -0500 )edit

Worked perfectly. However I do have a follow up question: When you initialize a catkin workspace, shouldn't that already be taken care of?

candidcypher gravatar image candidcypher  ( 2015-09-14 10:05:15 -0500 )edit

You can add the path of your catkin_ws in ~/.bashrc . sudo gedit ~/.bashrc add the path of your catkin workspace in bashrc YourPath/catkin_ws/devel/setup.bash and then run in terminal "source ~/.bashrc" And then you never get this error.

Zargol gravatar image Zargol  ( 2015-09-14 12:09:22 -0500 )edit

I had the same issue and I have already sourced the setup.bash. It turned out to be a spelling error in the command. I have typed beginner_tutorial"" instead of beginner_tutorial"s". If you get the same issue even after sourcing the setup.bash, double check the command to see if the spelling and names are correct. This might help.

Praveen Nellihela gravatar image Praveen Nellihela  ( 2021-05-21 05:49:17 -0500 )edit

answered 2013-10-21 15:13:51 -0500

Advait Jain gravatar image

Is there a space between the package name in your package.xml? I was having the same error in a different package and removing spaces inside <name></name> solved the problem for me.

Please see this issue for a possible cause of your problem.

edit flag offensive delete link more


i have this problem, and the package.xml file is correct, i don't have space in <name>beginners_tutorial</name>

bahaa gravatar image bahaa  ( 2014-01-01 09:00:23 -0500 )edit

answered 2015-11-29 11:45:18 -0500

Mike Zobot gravatar image

I came up with the same problem. Here is my first solution without checking this website. My error note is just the same as yours

[tutrtlemimic.launch] is neither a launch file in package [beginner_tutorials] nor is [beginner_tutorials] a launch file name
The traceback for the exception was written to the log file

so I try to edit the command, first you need go to the ~/catkin_ws/src/beginner_tutorials/launch and then type the commandroslaunch turtlemimic.launch . It works to me.

But I think what I'm missing should be source devel/setup.bash,after I go through this website. I tried it and execute the ~/catkin_ws$ roslaunch beginner_tutorials turtlemimic.launch

It works, I think we need to do source every time we made some new file or folder. Before we use roslaunch or other command.

edit flag offensive delete link more


Does this mean that the source command is used every time you create msg

summer gravatar image summer  ( 2017-09-20 22:19:23 -0500 )edit

answered 2019-11-28 09:27:28 -0500

Robotronics gravatar image

updated 2019-11-28 09:29:09 -0500

This error is directly related to the content inside the launch file you created. Just make sure that all necessary hashes and brackets are included as in paragraph 2.3 under this website

Also make sure when you create the file, that you have only one set of numbers on the left column. Because if you copy whats inside this paragraph on a new file, that has numbers directly embedded inside of it, creates an error in format.

edit flag offensive delete link more

Question Tools



Asked: 2013-10-02 06:20:39 -0500

Seen: 16,044 times

Last updated: Nov 28 '19