actionlib ABORTED status "sticks" between goals [closed]

asked 2013-09-25 03:48:42 -0500

Pi Robot gravatar image

updated 2013-09-27 02:50:38 -0500

Hello,

I am using the move_base action server and the SimpleActionClient (Python) to send a series of navigation goals to my robot. At the moment I am doing this in simulation, not on the real robot. My setup is Ubuntu 12.04 and ROS Groovy Debian install.

The problem I am having is that when a navigation goal is aborted because the goal cannot be reached, the next goal location in the list is also aborted even though it is perfectly reachable. It's as if the first ABORTED status "sticks" long enough to get attached to the next goal. Is there something I have to do after an aborted goal to clear the status? I've already tried cancel_goal() and cancel_all_goals() after a goal is aborted but it does not change the behavior.

Thanks,
patrick

UPDATE:

The following setup reproduces the problem 100% of the time. The nav_abort_test.py script moves the robot continually through 4 waypoints. The third waypoint is set right in the middle of an obstacle on the map so move_base has to abort. However, it then aborts on the next waypoint as well even though that waypoint is perfectly reachable which can be proved by commenting the third waypoint out of the script.

To reproduce the setup, follow these steps:

 $ cd ~/ros_workspace
 $ git clone <a href="https://github.com/pirobot/rbx1.git">https://github.com/pirobot/rbx1.git</a>
 $ rosmake rbx1
 $ roslaunch rbx1_bringup fake_turtlebot.launch
 $ roslaunch rbx1_nav fake_move_base_obstacle.launch
 $ rosrun rviz rviz -d `rospack find rbx1_nav`/nav.rviz
 $ rosrun rbx1_nav nav_abort_test.py

If you don't want to run all the steps above, the test script can be found here and the obstacle map can be found here. The navigation params for the fake Turtlebot can be found here.

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by tfoote
close date 2016-08-08 00:23:27.624972

Comments

Patrick, I haven't observed this -- and up until this past weekend when I migrated to hydro, I've put a lot of miles on our robot using groovy nav stack debs. Perhaps post a snippet of how you're using the SimpleActionClient?

fergs gravatar imagefergs ( 2013-09-26 01:36:00 -0500 )edit

@fergs - please see the Update to my question above.

Pi Robot gravatar imagePi Robot ( 2013-09-26 04:30:26 -0500 )edit