Error in running the Demo for hector Quadrotor [closed]

asked 2013-09-24 09:44:07 -0500

Neo gravatar image

updated 2013-09-24 10:08:23 -0500

i am trying to run Hector quadrotor demo. from this tutorial

i am getting this error when i run the command below

roslaunch hector_quadrotor_demo outdoor_flight_gazebo.launch

... logging to /home/neo/.ros/log/447c986a-2550-11e3-9561-87d85f24eea4/roslaunch-ubuntu-17732.log Checking log directory for disk usage. This may take awhile. Press Ctrl-C to interrupt Done checking log file disk usage. Usage is <1GB.

Traceback (most recent call last): File "/opt/ros/groovy/stacks/xacro/", line 35, in <module> xacro.main() File "/opt/ros/groovy/stacks/xacro/src/", line 554, in main process_includes(doc, os.path.dirname(sys.argv[1])) File "/opt/ros/groovy/stacks/xacro/src/", line 202, in process_includes raise XacroException("included file \"%s\" could not be opened: %s" % (filename, str(e))) xacro.XacroException: included file "/home/neo/hector_quadrotor_tutorial/hector_quadrotor/hector_quadrotor_gazebo/urdf/quadrotor_plugins.gazebo.xacro" could not be opened: [Errno 2] No such file or directory: '/home/neo/hector_quadrotor_tutorial/hector_quadrotor/hector_quadrotor_gazebo/urdf/quadrotor_plugins.gazebo.xacro' while processing /home/neo/hector_quadrotor_tutorial/hector_quadrotor/hector_quadrotor_gazebo/launch/spawn_quadrotor.launch: Invalid tag: Cannot load command parameter [robot_description]: command [/opt/ros/groovy/stacks/xacro/ '/home/neo/hector_quadrotor_tutorial/hector_quadrotor/hector_quadrotor_description/urdf/quadrotor_hokuyo_utm30lx.gazebo.xacro'] returned with code [1].

Param xml is <param command="$(find xacro)/ '$(arg model)'" name="robot_description"/>

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by tfoote
close date 2016-08-08 00:25:41.322092


Hi, have you solved the problem? I think I have got the same problem here.

StevenJiang gravatar image StevenJiang  ( 2015-06-28 21:38:45 -0500 )edit