Ask Your Question
0

I'm trying to install utilrb on fedora 19, I have ruby 2.0 already installed. If I understood, in utilrb_ext.cc inclusion, it would may included ruby-internal-1.9.h but is not the case, and so compilation does not work.. Can you help me? [closed]

asked 2013-09-18 05:25:43 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

/usr/bin/ruby extconf.rb creating Makefile

make "DESTDIR=" g++ -I. -I/usr/include -I/usr/include/ruby/backward -I/usr/include -I. -fPIC -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -grecord-gcc-switches -mtune=generic -m64 -o utilrb_ext.o -c utilrb_ext.cc In file included from utilrb_ext.cc:8:0: ruby_internals-1.8.h:14:20: erreur fatale: intern.h : Aucun fichier ou dossier de ce type #include <intern.h> ^ compilation terminée. make: * [utilrb_ext.o] Erreur 1

edit retag flag offensive reopen merge delete

Closed for the following reason question is off-topic or not relevant. Please see http://wiki.ros.org/Support for more details. by tfoote
close date 2013-09-18 14:21:08

1 Answer

Sort by » oldest newest most voted
0

answered 2013-09-18 09:41:24 -0500

I wish I could help, but your question is too convoluted for me to understand your context. It seems like more of a linux issue than ROS, anyway...

edit flag offensive delete link more

Question Tools

Stats

Asked: 2013-09-18 05:25:43 -0500

Seen: 173 times

Last updated: Sep 18 '13