Ask Your Question
3

rosmake rgbdslam_freiburg error in groovy

asked 2013-08-26 20:05:45 -0600

FfoNy gravatar image

updated 2013-08-28 06:54:35 -0600

This is my terminal information:

> mkdir -p bin
cd build && cmake -Wdev -DCMAKE_TOOLCHAIN_FILE=/opt/ros/groovy/share/ros/core/rosbuild/rostoolchain.cmake  ..
[rosbuild] Building package rgbdslam
-- Using CATKIN_DEVEL_PREFIX: /home/turtlebot/rgbdslam_freiburg/rgbdslam/build/devel
-- Using CMAKE_PREFIX_PATH: /opt/ros/groovy
-- This workspace overlays: /opt/ros/groovy
-- Using Debian Python package layout
-- Using CATKIN_ENABLE_TESTING: ON
-- Skip enable_testing() for dry packages
-- Using CATKIN_TEST_RESULTS_DIR: /home/turtlebot/rgbdslam_freiburg/rgbdslam/build/test_results
-- Found gtest sources under '/usr/src/gtest': gtests will be built
-- catkin 0.5.71
[rosbuild] Including /opt/ros/groovy/share/roslisp/rosbuild/roslisp.cmake
[rosbuild] Including /opt/ros/groovy/share/roscpp/rosbuild/roscpp.cmake
[rosbuild] Including /opt/ros/groovy/share/rospy/rosbuild/rospy.cmake
CMake Error at CMakeLists.txt:96 (find_package):
  Could not find module Findlibg2o.cmake or a configuration file for package
  libg2o.

  Adjust CMAKE_MODULE_PATH to find Findlibg2o.cmake or set libg2o_DIR to the
  directory containing a CMake configuration file for libg2o.  The file will
  have one of the following names:

    libg2oConfig.cmake
    libg2o-config.cmake




------------------------------------------------------------------

Compiling SiftGPU...
make[1]: Entering directory `/home/turtlebot/rgbdslam_freiburg/rgbdslam/external/siftgpu/linux'
mkdir -p ../../../build/siftgpu
mkdir -p ./bin 
ln ../data/ -d -s -f
ar rcs ./bin/libsiftgpu.a ../../../build/siftgpu/FrameBufferObject.o ../../../build/siftgpu/GlobalUtil.o ../../../build/siftgpu/GLTexImage.o ../../../build/siftgpu/ProgramGLSL.o ../../../build/siftgpu/ProgramGPU.o ../../../build/siftgpu/ShaderMan.o ../../../build/siftgpu/SiftGPU.o ../../../build/siftgpu/SiftPyramid.o ../../../build/siftgpu/PyramidGL.o ../../../build/siftgpu/SiftMatch.o
g++ -o ./bin/libsiftgpu.so ../../../build/siftgpu/FrameBufferObject.o ../../../build/siftgpu/GlobalUtil.o ../../../build/siftgpu/GLTexImage.o ../../../build/siftgpu/ProgramGLSL.o ../../../build/siftgpu/ProgramGPU.o ../../../build/siftgpu/ShaderMan.o ../../../build/siftgpu/SiftGPU.o ../../../build/siftgpu/SiftPyramid.o ../../../build/siftgpu/PyramidGL.o ../../../build/siftgpu/SiftMatch.o -lGLEW -lglut -lIL -lGL -lX11 -g -O2 -I../include -fPIC -L/usr/lib64 -L/usr/lib -L./bin -Wall -Wno-deprecated -pthread   -march=native -mfpmath=sse -shared -fPIC
make[1]: Leaving directory `/home/turtlebot/rgbdslam_freiburg/rgbdslam/external/siftgpu/linux'

------------------------------------------------------------------

-- Eigen found (include: /usr/include/eigen3)
[rosbuild] Couldn't find source file /home/turtlebot/rgbdslam_freiburg/rgbdslam/build/src/moc_qtros.cxx; assuming that it is in /home/turtlebot/rgbdslam_freiburg/rgbdslam and will be generated later
[rosbuild] Couldn't find source file /home/turtlebot/rgbdslam_freiburg/rgbdslam/build/src/moc_openni_listener.cxx; assuming that it is in /home/turtlebot/rgbdslam_freiburg/rgbdslam and will be generated later
[rosbuild] Couldn't find source file /home/turtlebot/rgbdslam_freiburg/rgbdslam/build/src/moc_qt_gui.cxx; assuming that it is in /home/turtlebot/rgbdslam_freiburg/rgbdslam and will be generated later
[rosbuild] Couldn't find source file /home/turtlebot/rgbdslam_freiburg/rgbdslam/build/src/moc_graph_manager.cxx; assuming that it is in /home/turtlebot/rgbdslam_freiburg/rgbdslam and will be generated later
[rosbuild] Couldn't find source file /home/turtlebot/rgbdslam_freiburg/rgbdslam/build/src/moc_glviewer.cxx; assuming that it is in /home/turtlebot/rgbdslam_freiburg/rgbdslam and will be generated later
[rosbuild] Couldn't find source file /home/turtlebot/rgbdslam_freiburg/rgbdslam/build/src/moc_ros_service_ui.cxx; assuming that it is in /home/turtlebot/rgbdslam_freiburg/rgbdslam and will be generated later
-- Configuring incomplete, errors occurred!
make: *** [all] Error 1
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
7

answered 2013-08-28 06:53:22 -0600

It is a known problem in groovy, that rgbdslam doesn't find libg2o. A hackish solution that worked for one person and didn't work for a second one is this:

delete the following line in rgbdslam/CMakeLists.txt

find_package(libg2o REQUIRED)

replace the following line

SET(G2O_LIBS ${libg2o_LIBRARIES} cholmod cxsparse)

by

SET(G2O_LIBS cholmod cxsparse -lg2o_cli -lg2o_core
-lg2o_csparse_extension -lg2o_ext_freeglut_minimal -lg2o_incremental
-lg2o_interactive -lg2o_interface -lg2o_opengl_helper -lg2o_parser
-lg2o_simulator -lg2o_solver_cholmod -lg2o_solver_csparse
-lg2o_solver_dense -lg2o_solver_pcg -lg2o_solver_slam2d_linear
-lg2o_solver_structure_only -lg2o_stuff -lg2o_types_data -lg2o_types_icp
-lg2o_types_sba -lg2o_types_sclam2d -lg2o_types_sim3 -lg2o_types_slam2d
-lg2o_types_slam3d)

I am not using groovy but I will happily patch rgbdslam if someone has a reliable solution to this.

edit flag offensive delete link more

Comments

Thanks for your answer. This is right.

FfoNy gravatar imageFfoNy ( 2013-08-28 18:08:31 -0600 )edit

I am the person that it worked for, so it's true working :D

RodBelaFarin gravatar imageRodBelaFarin ( 2013-12-02 08:28:51 -0600 )edit

I just wanted to add that I'm using ROS Electric and this fix worked for me. I followed this comment and it complied on the very next try.

KaiserUDM gravatar imageKaiserUDM ( 2013-12-03 17:38:23 -0600 )edit

This worked for me on Ubuntu 12.04.3 + ROS Groovy. Thanks!

thchung gravatar imagethchung ( 2013-12-07 06:21:30 -0600 )edit

this worked on ubuntu 12.04+ ROS groovy thanks

hgtc-dp gravatar imagehgtc-dp ( 2014-05-19 08:11:13 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

3 followers

Stats

Asked: 2013-08-26 20:05:45 -0600

Seen: 1,805 times

Last updated: Aug 28 '13